[Solved] Stuck on loading screen after updating to beta 6

I just bought the game on steam and I cant start a new game. Every time I try to start a game it gets stuck on ‘preparing businesses and mods’. I left for about 45 minutes and I came back and it still hadn’t moved. I don’t have any mods installed and i’ve tried verifying the files and reinstalling. Im running on windows 10.

Very strange, we’re investigating the issue and will push a fix immediately. Just updated to beta 6 yesterday so there’s probably some issue here.

Edit: We might need to check out your log file, it’s located here: C:\Users\USER\AppData\LocalLow\Apoapsis Studios\Airport CEO and the file name is “output_log” - could you send it to support@airportceo.com?

1 Like

Hello guys, I need your help, I just updated my Game on Windows and something happend to me, when i want to load my airport from beta5.1 and playing in 6.1 and im stuck in loading screen says “Preparing Business and mods” its take 30 minutes and nothing happend. Please help me

1 more thing, just unmods all my mods and still same doesn’t works!


Does it affect only existing savegames or also new maps?

existing savegame and new maps, stuck on the screen

I would suggest to reinstall the game and check if it works then. :confused:

Savegames should stay but can also be saved to be sure they don’t get lost:
For Windows you find them in %appdata%\Apoapsis Studios\Airport CEO\Saves

Subscribed mods will download again afterwards.

I see a similar report on Steam.
Could be the same issue as in Beta 4 @Olof
Airport CEO Beta 4 released - #58

All my savegames still there. I just reinstall the game but when i trying to load and stuck again n again
any clue?

Yeah maybe Olof should fix this issues. Always stuck on my screen over and over again

We’ve most likely located the issue. Will push at hotfix to the default branch in a few minutes.

Please make it fast, its kinda boring not playing this game.

1 Like

I agree, I also prefer to be playing this game most of the time, especially compared to not playing it!


I dont have this file

Try look in the Player.txt-file. I think you will have an error somewher regarding the Templates-directory isn’t existing?

We’ve hotfixed this issue on both the experimental and default branch. Update the game and loading should now work! :slight_smile:


I dont know where is it:(

Thank you! I can play now!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.