[SOLVED] (PC) Newly re-installed game not loading


I’ve played Airport CEO some time ago but I got rid of it because of an computer issue. Now that my computer problems are gone, I’ve re-installed Airport CEO. I tried to launch a new game , selected my airport’s location, CEO and name/code, hit the let’s go button and waited. The games starts showing-up its loading screen and stops while “Loading game world”.

I’m using game version Alpha 27.8-3, with no mods on a brand new empty game. I hope someone can help me otherwise I’ll simply wait for the next up-date.

  • System : Windows 10 x64 (1607, the new one brakes my computer, that was the issue I was talking about sooner)
  • Processor : i7-3770 CPU 3.40GHz
  • RAM : 8Go
  • Graphics card : GTX 1060 Nvidia

Thank you in advance

I’ve just started a new game and didn’t have any issues. I’m on a Mac mind you though. Have you updated your graphic card drivers? Is it just this game that hangs?

Let me check for my drivers but I’ve been waiting a cuple of hours and I didn’t move an inch

My drivers are up-to-date … unfortunately it might come from the game files …

A suggestion to see if it’s something with new game or not, subscribe to a map that’s been put on Workshop, and see if that loads?

What do you see if you look in the output log file?

Initialize engine version: 2017.4.4f1 (645c9050ba4d)
GfxDevice: creating device client; threaded=1
Version: Direct3D 11.0 [level 11.1]
Renderer: NVIDIA GeForce GTX 1060 6GB (ID=0x1c03)
Vendor: NVIDIA
VRAM: 6064 MB
Begin MonoManager ReloadAssembly

  • Completed reload, in 0.094 seconds
    Initializing input.

Input initialized.

Initialized touch support.

UnloadTime: 1.070094 ms
Setting up 4 worker threads for Enlighten.
Thread → id: 15bc → priority: 1
Thread → id: 20f4 → priority: 1
Thread → id: 17a4 → priority: 1
Thread → id: ca4 → priority: 1
Unknown error occurred while loading ‘level1’.

(Filename: Line: 147)

Unloading 6 Unused Serialized files (Serialized files now loaded: 0)
UnloadTime: 8.902161 ms

Unloading 19611 unused Assets to reduce memory usage. Loaded Objects now: 10319.
Total: 28.241745 ms (FindLiveObjects: 1.029947 ms CreateObjectMapping: 1.697058 ms MarkObjects: 7.576089 ms DeleteObjects: 17.938348 ms)
This is what it says … I’ve only understood the word error lol

@olof Do you know what might be throwing the error?

Sorry I haven’t said that the steam workshop save dosn’t load too

I have no clue :c

It sounds more like a local issue with your individual configuration then.

This is wierd, on older versions , the game used to work on my current configuration. Well, I will need to go deeper into the issue.

Have you tried completely purging Airport CEO and all of its associated folders?

Are sure you’re playing the game as an admin (right click and select “run as admin”)?

Thank you for the suggestion , I will try that

1 Like

Just needed to make a steam file check … sorry for disturbing, I feel a bit dumb right now lol. Thank you very much for your time.

1 Like

Hello! I have a simillar problem, please visit