[Solved] Game Freezes Then CTD

After the R&D update, I haven’t been able to play for more than 10 minutes. I’ve had this issue in very early versions of the game and then it went away. The game launches normally and I can play for 10 to 15 minutes then the screen freezes and then after a few minutes, the game crashes. The audio is unaffected as I can still hear airport operations in the background. I can even hear my mouse scrolling over menu items.

When looking at the output data, there seems to be some sort of d3d11 error; d3d11: failed to create buffer (target 0x1 mode 0 size 3408) [0x887A0005]. I’ve tried using the steam launch code: -force-d3d9, running as administrator and running in Windows 8 compatibility mode.

This seems to be an isolated issue as I can run other steam games like Prison Architect and Sim Airport just fine.

Here are some lines from the output log:

d3d11: failed to create buffer (target 0x1 mode 0 size 48) [0x887A0005]
d3d11: failed to create buffer (target 0x1 mode 0 size 32) [0x887A0005]
d3d11: failed to create buffer (target 0x2 mode 0 size 12) [0x887A0005]
d3d11: failed to create buffer (target 0x1 mode 0 size 48) [0x887A0005]
d3d11: failed to create buffer (target 0x1 mode 0 size 32) [0x887A0005]
d3d11: failed to create buffer (target 0x2 mode 0 size 12) [0x887A0005]
d3d11: failed to create buffer (target 0x1 mode 0 size 48) [0x887A0005]
d3d11: failed to create buffer (target 0x1 mode 0 size 32) [0x887A0005]
d3d11: failed to create buffer (target 0x2 mode 0 size 12) [0x887A0005]
D3D shader create error for vertex shader [0x887a0005]
ShaderProgram is unsupported, but because jobified rendering is enabled the ShaderProgram can not be removed.

(Filename: Line: 436)


Can you post your hardware specifications? Are you using Windows 10 or 8?

Windows 10

Intel(R) Core™ i5-4210U CPU @ 1.70GHz 2.40GHz

6.00 GB DDR3

Intel(r) HD Graphics Family 2GB

Not the most powerful, however, I have been able to run ACEO on Graphics Quality: ‘Fantastic’ without any lag.

Judging by that log it seems as if you’re running out of VRAM, especially since you’ve got an integrated graphics card. Forcing to DirectX 9 does not sound like a good solution, I would instead make sure that all your graphics drivers and other drivers are up to date. Can you verify that? You should be able to at least run on DirectX 10.

I presume that if you just launch the game in a new world the game runs fine but it’s under load of a pretty large airport that you experience CTD?

All drivers are up to date.

It doesn’t really matter if it is a new world or a huge airport. The freeze & CTD happens most often when zooming in / out or moving around the map. I suspect it is a RAM issue also, however, it is suspicious that there are no such problems with any other games.

What if you run it with the correct DirectX settings? It should be the latest possible and not in any specific compatibility mode, that only makes things worse.

Not all games function the same so I can’t speak for them, but in ACEO we pile a lot of stuff on the GPU - as much as possible to relieve the CPU of all the other simulation stuff. I don’t think your RAM is an issue here and if you CTD on an empty world within the same scope as for a large airport there is something particular going on. Can you drop the full log file to support@airportceo.com?

Okay, sent.

Thanks. Just for ruling things out, can you try the following:

  1. Open you computer’s display settings and change the resolution to something else than what you currently have applied
  2. Change it back to your previous, preferred, resolution setting
  3. Launch the game

… and see if this yields a more stable experience?

It worked for about 25 minutes, then the freeze and CTD occurred.

I found this in the error log, don’t know if it is relevant.

Airport CEO by Apoapsis Studios [version: Unity 2018.4.19f1_459f70f82ea4]

UnityPlayer.dll caused an Access Violation (0xc0000005)
in module UnityPlayer.dll at 0033:dac5a818.

Was this on an existing airport or a new one? You could start a new one and simply let the screen run for a while and see if you have the same stability issues?

It was on an existing airport, I tried starting a new airport and after a few minutes, the same issue occurred.

As I mentioned earlier, I had this same issue back when the game was just released and then it disappeared and I’ve been able to clock 145 hours on ACEO since. So, I’ll wait until Alpha 35 is released and see if the issue resolves itself.

Thank you for all the help!

Strange, we did upgrade the game engine version in the last update. If issues persist in Alpha 35 let me know and we can see if we can run a test on a separate branch with the previous version.

1 Like

I’m having a similar issue to the OP with regard to seemingly random crashing. Like the OP, I initially had issues similar to this way back when the alpha first came out, and then over a few patches and updates the problem went away. I’ve only been having these latest crashes as of Alpha 34. I have this issue with new games as well as existing saves.

Initially, each crash would actually end up blue screening my PC to force a reboot. The error messages were generic, and seem to point to a problem with a driver or a hardware fault. Like the OP, I’m having no issues running other Steam games though (Hearts Of Iron 4, Hell Let Loose, etc), so I don’t think it’s a hardware fault. Here’s the basic troubleshooting I’ve done to this point:

  • Performed a chkdsk run on the drive where the game was installed and found no issues. No behavior change for the crashes with me still getting a blue screen.

  • Uninstalled and reinstalled the game on the initial drive it was on. After the fresh install, it appears that I can play the game for a longer period of time before I run into the crash issue again. Once that first crash happens, the interval from game startup to crash is about 10 minutes on average. I managed a few hours of play after the reinstall.

  • Ran Steam as admin and this changed the crash behavior to a simple crash-to-desktop symptom as opposed to the blue screen. the interval of crashes is about the same. I’m not convinced this behavior change can be linked to the admin run though, given the other variables in play.

  • Deleted all old saved games. No change.

  • Moved the game files to a new SSD drive and met the same crash behavior. I then did a fresh install on the new drive and was able to play for a few hours again before the first crash occurred.

  • Went through and updated all my drivers via the Device Manager window. No change to the crashes after this was done and the PC was rebooted.

At this point I figure I’m just going to wait for Alpha 35 and hope that this issue is resolved with that build.

My PC is a custom-built machine with the following high-level specs:

Win 10 (Auto update install enabled)
GeForce RTX 2080 Ti
Intel i9-9900KS 4.00GHz

All right, I’m going to deploy a version of Alpha 34 to our internal test branch with the previous engine version. Can you both drop me a PM here on the forum and I’ll send you the instructions on how to activate that branch so we can test out if it’s the new engine version that’s causing these issues.

Also, @wizahh101, can you verify that for your integrated graphics card you actually have the max amount of VRAM assigned? Some integrated GPUs allow up to a certain amount of VRAM but its not assigned by default.

It does not look like I have the ability to PM, given that I created this account very recently. I’m assuming that’s a functionality that is unlocked over time?

I’ve been continuing my troubleshooting on this end and I was able to cause a similar crash when I installed and ran Subnautica on my PC. So this appears to be a more general issue with my PC than Airport CEO. The BSOD code is now coming as an IRQL_NOT_LESS_OR_EQUAL, which points to a driver/memory issue. Each crash is now a 50/50 chance between the BSOD and a CTD. This is only happening for Airport CEO and Subnautica at this time, with my other games being unaffected.

I’m continuing with my troubleshooting efforts with a focus on anti-virus (Avast) and other potential causes.

1 Like

Does sound strange, it could be Unity related if Subnautica is developed with Unity.

It seems that Subnautica does use Unity. In addition to that I’ve come across several different online message boards with people, using very similar PC builds to mine, experiencing identical BSOD events when running games that use the Unity engine.

This troubleshooting thread gives a very good breakdown of the issue I’m facing (takes some back and forth before a root cause is tracked down): MSI Global English Forum - Index

If I understand it correctly, the issue is a hardware/BIOS shortcoming on my MSI MB where it’s not supplying the correct voltage to my CPU. It seems that the Unity engine has a habit of spiking CPU load before nosediving down to a low. It’s during that nosedive where the voltage on the CPU drops too much and generates instability. That would explain why I was getting all sorts of various BSOD error codes. This also explains why a lot of my BSOD events happen during near idle game play when I’m not doing much beyond moving the mouse.

It seems that the fix, in my case, is to offset my CPU vcore range by +0.025V to prevent the CPU voltage from dipping below the min threshold when the Unity engine drops its load factor. Others have tested this and indicated it does prevent the crashes. I will test this and see if it resolves the issue.


I can confirm this… :stuck_out_tongue: … we’re doing our best to mitigate spikes and will do a lot more optimization before a full release but indeed, computers exposed to the issue you’re describing will have a harder time running the game stable.

Very well researched and dealt with! Would be amazing if this could solve the issue and I bet a lot of other people with a similar problem will end up here if that’s the case.

1 Like