My Game still crashes when trying to start a new game

Hi all, I made a post about this a few months ago about how my game would always crash when trying to load mods into a new save on the loading screen. At the time, there was no concrete help and so I gave up and haven’t tried in a few months. I am back at it again and I have tried to pair down the amount of mods I am subscribed to, but frankly I don’t want to play this game unless I use real airlines and businesses and not default ones. I got my number of mods subscribed to down to 29, but my game crashes every time I try and start a new airport. It looks like my game gives out after loading what it calls about “120 businesses and mods” out of 141 even though I am only subscribed to 29 actual mods. The game opens up Unity Crash engine every time it crashes and so I am wondering if there is any way to look at these logs and see what or why my game keeps crashing. Here is the link to my previous thread: Thanks in advance!

Hi wiirocks86,

I don’t know if this is the solution for your problem but you can try a few things.

  1. Go to the Steam Library
    Right click Airport Ceo and select Properties
    Under the General Tab click “Set Launch Options”. A dialog box will appear.
    Type in “-force-d3d9” (without quotes) and hit OK.
    Check if there is a difference when you start a new game.
    If not, undo the changes and proceed to step 2 :

  2. First go to C:\Users\YourUsername\AppData\Roaming\Apoapsis Studios\Airport CEO
    Delete GameSetting.json. This will reset all previous made settings and all mods will be deactivated.

Open Airport Ceo and start a new airport. If it doesn’t crash I’m pretty sure a mod is causing the problems.
If this is the case go to your steam folder Steam\SteamApps\workshop\content\673610.
Delete all folders inside the 637610 folder.
Then go to the Airport Ceo Workshop/your files/subscribed items.
Hit unsubscribe then resubscribe your mods one by one. Wait until steam has finished downloading.
After this open Airport Ceo and go to the modding section. Enable the mods a start a new game.

Thank you so much! Whatever the first step did fixed my game and it works great! May I ask what that launch option does?

It will force the game to use directx9 for rendering.
This is a common solution for APUs or older graphics cards.
But your problem is also caused by outdated drivers so check if this is not the case.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.