Modding for Mac

Have any of you managed to add mods on Mac into the game? If so would you be able to show me how to do it?

Many thanks,

Hi Matt. What would you like to know? Been modding since day one.

Paths to where Mod needs to go.

You might need to enable Library view?

Hi Matt

I’ve started using the mods today for the first time on my Mac. You can’t use the mod manager as it’s windows only, but you can copy the mod files to your airportceo data folders and it works fine.

I’ve used the global and European mods and not had any issues.

The link below has some helpful information.

this link

Edit: if you haven’t enabled library view on your Mac, you can open the correct folders by right clicking on the airportceo desktop short cut and selecting “show pacakage contents”.

1 Like

As a fellow Mac user I’m always happy to help get Mods working. I’ve just been doing some 757 work as well. Companies are just as easy. We may not have the excellent Mod Manager programme but we can use them all.

This is my flight planner. Most of it is Mods.

Hi EC, cool UN too. :wink: Always good to meet to meet fellow Mac users.


To use the files from the official MM respoity you will also need to download ‘The Unarchiver’ which is available in the Mac App Store (Free). It uncompresses the 7z (I think that’s that file type, dang you memory) but that will let you open them for you too.

Good point. I’d forgotten you need that - already had on my Mac but guess not everyone will. Yes it’s a 7z file to unarchive.

Glad to see some other Mac users. I know who to trouble now when I get stuck… :rofl:

1 Like

Anytime. I actually make a lot of Mods too and submit them to MM. All of the mods in the flight planner are mine and some other too that are not there. The ACEOMM has a very rich community. If you want to know more just ask @pderuiter or @EG0611.

Anything Mac related I’m here too.

I’ve put it into the folder, but it doesn’t run when I open the game, the game just runs the same. Any reason why it may do this?

What have you put into the folder? Airline, Company etc? What specifically?

It’s Data Files → Companies → VulcanFoxPack (The MOD I tried installing) → Airlines

1 Like

Ah the most excellent @VulcanFox pack. They are sublime yes. Okay.

They need to go here. They should not be nested. Each airline should be at root in the mod airlines folder.

1 Like

I don’t have a mod folder, where can I get it?

You will need to navigate there and make it yourself as is make a new folder. You will need to have library view enabled.

This is my full path. Obvisuly I guess your’s is Matt not Steve?

If you cannot see your Library folder, then when in Finder, go to View and show it’s options from the menu bar, and select it there.

Does this look correct to you?

It does not go back far enough. Look at my path from library.

they are exactly the same before, just saving myself some time.

No something looks off. I don’t have an CEO_Data folder. You need to right click on the Airport CEO icon and show it’s contents. That will lead you to the correct file paths.

Are you up and running? I have to go now. I’ll be back later to answer questions, queries.


I worked out the problem, I was creating a new file instead of opening the program to show the contents. Thanks for the help, however!

After I have implemented the mods, which I have done so, when do they load into the game? They don’t seem to appear for me after I start the game.
Also, where can I get the mods that you got on your Mac? I’ve looked through the mod section here and can’t seem to find any more. Thanks :slight_smile:

Apart from the VF pack, I made all of the others and they are submitted to MM for inclusion (apart from WIP ones) which I believe they are? We need to ask @pderuiter if he’s updated the data files on the Drive where you downloaded them from. If not, that’s why they are not there.

The airline contracts appear over time. They don’t just populate the contracts section.

1 Like