Low Performance - CPU usage 99%, FPS low, Hight temperature

I’m facing a serious performance issue in the game (v1.0.35) High CPU usage (99%), high temperature, (+90ºC), minimum FPS.
This problem I only have with this game. Using Prepar3D, recording with OBSStudios, rendering videos, I can’t stress the CPU as much as this game can. Please, I ask you to help me to solve the problem. The error happens even with as little play as possible - (low pax level and few acft). Follow prints.

It really depends on how many objects you placed. The game hasn’t been optimized from the start, and it is unfixable.

Number of objects? I believe this is not the case. It happens that I see airports much more detailed than mine (Youtube, Steam, Saves) and that run without problems. It also happens that several other players have already reported the same problem here. And this has been repeated. See other examples of other players and their built structures - you will see that the problem is not the amount of objects placed.

I know it doesn’t fully depend on objects, but it is a part of it. Your computer specs may not be right, and/or you make the passengers pathfind a long way which greatly increases the fps issue.

I don’t understand… the configuration of my PC (hardware?) or the configuration that the game runs?

as for the long path, it is doable. But a long way to be the cause… I don’t know. I think it’s unlikely.
Anyway, I read a developer post that cites two problems for this to be happening. Turns out he only spoke of 1. He has released an update for that. The version I use is already an updated one, and the problem still persists. That’s why I think “long paths” are not or at least have no relevance to the problem".
Anyway, how to fix?
See in this new save: there is a queue that extends throughout the terminal, it has many objects, several stands, two lanes, several parking lots, 03 levels, and everything else that is in the first save. Realize the amount of pax! Number of Acfts! Staff!
The problem can never be queue size or number of objects!
Finally… see the FPS (+30) and the temp (84ºC)

Lots of persons executing complex paths will usually put a lot of computational load on your system. Does this happen on all of your airports, if you have any else, or just this one?

1 Like

Good morning Olofo. The problem happens in every airport I create. Be it small or medium size. Whenever I start with medium aircraft, the problem appears. I’m not sure if this is the trigger, but invariably, when starting operations with medium aircraft, the problem is certain to appear.

Have you tried verifying the game files?

I don’t understand… check the file?
How to do it and why? What should I look for?

Under Steam you can right-click the game and go properties and verify the game files. Just a precaution that the game-code is as intended and has not been corrupted.
Imagine the game needing a file but the file is bugged. The game can enter a loop and tries to request the information of the file over and over and over and those processes might stack up in your CPU. Nevertheless, it is always a good thing to look if the game files are intact, if a bug occurs.

Thanks for teaching. I didn’t know about the feature.
Yes, the files are intact.

Good - so at least we know we cannot attribute the bug to faulty files. Keep this feature in mind. If software under STEAM does not work properly, it is always worth to check game integrity first before submitting bug reports. But in your case you have high CPU so one might ask, what is occupying your CPU all that time. We see it is ACEO, but why? Looks a bit like a dog trying to chase his tails - never getting it but keeps spinning endlessly.

Please I really need help to resolve the reported issue.
An airport with 4 stands, in these gameplay conditions?
It doesn’t have details, it doesn’t have excess objects, it doesn’t have giant queues, it doesn’t have big movement… in short… nothing that justifies it!
It’s frustrating to want to play and not be able to!

The game just DOESN’T RUN!

How can?
closed airport, with no one, no queue, no aircraft, nothing, in with this performance?

Do you play with active Mods?
If yes, have you deactivate this and start a new airport?
If no, have you reinstall the game?
Have you temporarily switched from default release to experimental release?

Otherwise I have no idea what is going on.

hello Domi…yes, I use mods… but just to test, I disabled them. I thought it was some mod that was causing this.
Although I have the ACEO for more than 2 years, it is a recent installation. I had stopped playing precisely because of these legs that occurred. I thought it was because it was a beta version. Then I reinstalled and started playing again about 2 weeks ago. It continues in the same way.
The first prints were from a game with mods. The last one was totally default - without mods and with the files checked, as suggested by DocDesastro.
I have an i7 7700k overclocked to 5GhZ enabled, hydrocooler installed and 16gb of RAM. My video card is a 1070. How can?

Look at this structure:

how is it possible? They talked about queue size, number of objects, terminal complexity… just take a look at the prints! How can it run smooth on a PC and on mine the game crashes?
Again I say…
It’s not a question of the queue, the complexity of the airport (it’s okay that there are some players who are on the verge of madness…), number of objects…
The problem is another!

Problems like these are always difficult to debug, especially when it seems that the issue is tied to a specific device and not an issue in general. Please see if you can bug report that save in the most recent state, with around 700 passengers, and let me know the number here and we’ll have a look at it.

Hi Olof…
So… I went beyond 700pax as suggested… I’m running smoothly with +5000pax registered for the day. And no bottlenecks in the processor. I uninstalled ACEO, deleted the registry files, uninstalled Steam, deleted all installed games from Steam and installed everything again. I added the mods I use, 1 by 1 and the game flowed. I haven’t added any parking yet as you can see in the print. I’ll just do it after building the entire terminal and detailing it. I’m doing it part by part… first letting it run with the minimum necessary, then adding walls, decorations, extending the zones and little by little making the airport grow. So far, it’s working.

In any case, I appreciate the help of those who were willing to understand the problem and seek a solution. It seems to me that reinstalling all of Steam solved the problem.

Now if you can help me with some questions, I would appreciate it…
1- the pax of the heavy gate do not disembark… they are all on the boarding bridge. and the output is not blocked. Why could this be happening? All the way to disembarkation and luggage is unlocked and functional (see images). So why don’t they just move on? Do you have any idea?

Look what’s happening: The acft leaves, but the PAXs are crowded on the boarding bridge, and some who leave, stay in the bathroom and everyone with the exclamation icon.

2 - Is it mandatory to have the catering and cleanup services of the acft to receive heavy acft? Only with luggage and active fuel, I can’t receive it? Even having searched for this facility in the control panel?
3 - My automatic flight scheduling is not working. For this to happen, I have to manually place a flight and only then does it keep scheduling. This happens every time I sign a contract with a new company, or open a new stand. I always have to manually add a flight for the flight scheduler to work properly. Is this correct or am I doing something wrong? Can you help me?

Thanks a lot for the help.


In my experience, Issue #1 is solved if you drag the international zone tool over the spot the trapped people are on. This happens to me when I build my jetways all the time. The arriving passengers are trapped until I drag the zone over that area again, then they all move in a mass exodus.

#2. Not in my experience. These increase your rating, I have not seen catering or cleaning mandatory for large planes.

#3. It looks like you need to allow the arriving passengers some passport checkpoints to leave the international zone into a regular secure zone. They cannot use the security exit in the international zone. All international zones need passport checkpoints to enter and exit.

I hope this helps.

Hi foxxygaucho…
So… I’ve already tried that of dragging the zones again… Both the red and the blue, including extrapolating the area. But it doesn’t! They’re still crammed in there.
But one thing I didn’t know (I haven’t gone through the tutorial yet, I’m sorry about that) is that I also needed the passport checkpoints for exit… that must be why!

What about the automatic flight scheduler? Any idea?

Furthermore, thanks for the comment. I’ll post here as soon as I manage to place the passport checkpoints at the exit, to see if it solves the problem.

problem solved!
Checkpoints at the exit! Thank foxxygaucho

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.