Cant find their way - Dual security

When using dual terminals / security check points, passengers cant find their way. When you look at the mapping, they are trying to exit from the check point on the other terminal. The Secure Zone from terminal one and two do NOT connect either. So it just floods the screen with about half the passengers when they deplane.

Version 28.1.5

would have included more pics, but im only allowed one???

Can you show same screenshot with areas enabled? I suspect that you also marked stands and taxiway area as secure.

The stands are by default, did not add any to the taxis, and their is a large gap between the two zones.

Hmm that is quite strange. You should file a bug report.

If you click on the security desks or stands you can check to which they are connected, is that separated in the way you expect it to on all?

As far as I know peoples pathfinding doesn’t support multiple, separated security zones yet. So the whole terminal needs to be a connected single one to work. This path finding is planned to be enhanched some time in the future of course, so separate terminals will be possible then.

For now if there are separated terminals, people may enter the wrong one and will get stuck.

Please have a look at this thread, did some testing with it and it works when you clearly separate the zones.


In theory that should work yes, but can’t really know until I get the save and have a closer look why it doesn’t. Have you tried a reload of the world? That will force the security areas to re-generate.

1 Like

Well due to stuck people and vehicles seems I’m reloading about ever hour right now.

That aside, im just going to merge security in the middle into one.

Don’t do that, instead send you saved airport in an e-mail to so that we can test it and see what doesn’t work and - fix it! :slight_smile:


@Olof Do you know if the bug around security zones that are separated after creation or have been connected and separated again is already solved? The only way to solve it now is a save and reload.

Edit: The same for security/staff zone ‘residu’ after deleting a stand.

During the course of this issue, their where many saves and loads. Now for no reason, this is no longer an issue. I did not change any part of that side, just worked on adding more gates and no longer get the routing error…

This is probably because you did the S&R’s, that causes the game to delete the old secure zone connection(s). As said above, this is a known issue with the devs, but not solved yet.

Would also be nice if personnel could jump the security line

I know you can built a separate security station for personnel only, but that’s not really cost efficient…

If you get enough passengers to be holding up the line, you can afford that extra security station for staff.