Aircraft paused across airport, game still running


All my aircraft have paused with no clear location for the block/glitch as per screenshot - any help appreciate as the savegame is not playable unless I can resolve it :frowning: fingers crossed there is a solution!

No animal issues or emergencies that I am aware of - has happened suddenly without any noticeable change or building work.

Yes that’s currently an issue since the other pathblocking issue has been solved.

No timeout - so is my savegame ruined now? :frowning: They are all stacking onto each other with no apparent way of fixing it

On my XXXXL airport, they started to overtake the locked plane and later they solved the issue… until the next plane got stuck. Yes, currently it can be very annoying.

Sounds like a critical bug @Olof? But i’ll stay optimistic and hope there is a solution to not running into an airport killing situation :wink:

I mean, for larger maps (which seems to come in Beta 3), the situation before was a gamebreaking issue when planes were blocked for hours because of others.
So far I play happier with the new bug. :smiley: But I’m looking also forward for a solution.

Reality is, we now have a total deadlock bug, rather than an “inefficiency” situation. I know the devs will resolve it but it seems to be quite a critical issue if instead of less-ideal taxiway routes and give ways, they now just deadlock without any solution possible leaving an airport unplayable.

Seems to be tied specifically to your airport designs, I have no other reports in the backlog on this issue other than the one you made and am running a few different airports on a few different machines without any issues as of now. Will continue to monitor this and I’m sure Fredrik will have a look at the save tomorrow but at this point it only seems to affect only a small amount of players.


Maybe some form of triggered “refresh” if deadlocked for too long or if taxiways limits added (to resolve a deadlock by making a suspect taxiway to oneway to force a new taxiway route?) Thanks :slight_smile:

Any news? I’ve tried everything but theres no way I can find that will resolve the deadlock. The small aircraft shown holding just short of the actual holding point, and the aircraft waiting to push back far left in both screenshots seems to be the issue :frowning: Is there any way in my save game that I can trigger aircraft to clear?

Can you take a look at this @Fredrik?

1 Like

After a few tries of the F10 aircraft path finding reset it did work :smiley: i seemed to have to do it immediately as the save game loaded for it to work. My guess is the aircraft exiting the runway was forcing a path through existing aircraft routes causing the deadlock but that is just a guess.

1 Like

All right, that’s good to hear, does it keep happening or was it this instance only?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.