[ACEO-39211] Text labels missing Mac Apple M1 chip?

I submitted a bug report in game for: ACEO-39211. Basically I have a new Mac Mini with the Apple M1 chip in it and wanted to try out the game. When I installed it it seems to work fine until I goto a page with color contextual boxes. Like the green buttons with white text, the flight board screen, vehicle screen, etc… Most of the other text in the game seems fine but this is gamebreaking. I have an existing Macbook Pro with Intel chip and everything looks good. Seems like Rosetta 2 is having an issue and assume this would be more Unity related instead of Airport CEO directly but wanted to bring it up in case someone has other thoughts. I found another Unity user possibly having a similar issue: https://forum.unity.com/threads/text-missing-on-apple-m1-mac-builds.1021987/ no idea if this is the same issue but worth linking here.

I have found a similar issue that was flagged as unable to reproduce (assuming devs don’t have an Apple M1 based Mac to try it on): Log in with Atlassian account

I have attached an image from that issue since I can’t easily get to mine right now to take another screenshot and my submitted issue is still private.

Any thoughts on this or just hurry up and wait since the M1 is still new and Unity will probably fix?

1 Like

As a fellow Mac user would be interested to hear what the performance is like on the M1.


Yeah I’ve seen this. The M1 is so new and experimental that I wouldn’t recommend running ACEO with it at this point, at least not if you’re looking for a stable experience. The issue is indeed as you say located with Unity and not something we can do about, I’ve checked around a bit and they are aware of it so I assume it’ll be fixed within one of the upcoming LTS releases. I’ll continue to keep an eye on this.



Having a bit of an issue in that a lot of boxed text seems to have disappeared. Most of the time not a major issue, but notifications for example I can’t see what the problem is because there is no text.

Have reported the bug but not sure if this has happened to others and if there is an easy fix. I have restarted the game multiple times and tried opening different saves. Am playing the latest update but has been a problem for the last two updated versions.

Appreciate the help

Interesting, are you playing on PC or MAC + what are your hardware specs? And Beta 4 or Beta 5?

1 Like

I am pretty sure you’re on a new MackBook Pro M1 right?

1 Like

Indeed. So the computer is the problem?

It’s not the computer, Olof mention Unity is likely the cause. See here…

1 Like

Ok, makes sense. Thank you

Interestingly enough, the game runs fine in pretty much every other way apart from this very strange issue

Yeah, I mean the M1 is as fundamental of change as a changes can get so it’s not surprising that not everything works. We can’t really get our hands on an M1 right now and Unity is aware of the issue so we’re better of waiting for a fix from their engineers, we’ll of course publish and update as soon as that happens. But until then we can’t do anything else than simply recommend that you don’t play the game on a M1 machine… :frowning:

1 Like

There seems to be a temporary fix now as the issue appears to be related to the Metal API, using “-force-glcore” as a launch option could fix the issue but would be dope if anyone could verify this. Not sure how this will affect performance though.

That seems to fix the issue in Beta 5! I’m not sure on performance changes as didn’t play much with it prior to changing that since I couldn’t do much with the missing UI. I loaded my airport with about 2k passengers and at 3x speed it did micro-stutter a couple of times when panning across the entire airport but not too bad. I was just able to pop in and try the launch option fix so didn’t get to test out anything further. Thanks for following up with a temp fix!

1 Like

Yes I’m having the same problem with my M1. Performance is AMAZING, but text boxes not functioning. I spent all xmas day building a mega airport, so I hope you can have this fixed soon!

Did you try the launch options solution we wrote about above? All other M1 players have solved the issue with that fix.

Thanks Olof. I’m not a very technical player when it comes to coding. Can you give me a bit more advanced instructions on how to use this code? In terminal? -force-glcore

I think it’s in Steam…

EDIT You found before my edit, excellent :slight_smile:

1 Like

never mind figured it out using Steam. Thanks Olof. Great job on this game. I love it.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.

Hi everyone, we need some help to troubleshoot this missing text issue. From the Unity forums we might have found a possible culprit and solution. However we have no computer in house with an M1-chip so can’t test it ourselves and want to find a more robust solution than altering the Launch Options.

With the next release (beta 7.1-2) (not the hotfix Olof just pushed), the “fix” will be implemented, and if someone could test it (remember to remove the launch options) that would be greatly appreciated! :airplane: