Weird Error after 40 hrs play time


Hey guys does anyone seen something like this before and how did you fixed it, please advise.
This error poped up after 40 hrs of playing it. I havent touched any drives or my system in general, I am so confused.


You might have to reinstal your game or switch from the experimental to the default branch.
This person had the same problem Game don‘t start, crashes while launching!

EDIT: Seems like you changed the picture :slight_smile: this is a problem that’s not related to ACEO if I have to guess. Do you have the same problem with other games?


My initial thought is that this is not related to us but we need some logs to look at to know if its really ACEO related or not. Did you try resetting the resolution as mentioned on our known issues site? What about reinstalling your graphics drivers?

hi, I did reinstal the game, I have updated my drives and still nothing helped.

‘’ switch from the experimental to the default branch. ‘’ - can you please advise me how can I do this option?!

Go to your steam library, right click on AirportCEO, select properties, go to BETA’s and from the dropdown select default.

But since you don’t know how to change that, you’re probably on the default branch.

1 Like

rest of the games run perfectly, only ACEO is crashing…

thank you, I’ll try this home tonight and will report back!

1 Like

Does the crash produce any log files?

It does but I am not able to open them and see what is the issue as pc crashes and I lose the file too… it doesnt save itself regrettably. I tried to find it (report) with pc search option and nothing comes up.

Does the app crash to desktop or does you entire PC crash and you have to power cycle it?

it crashes to desktop but If I dont do anything about it (like cancel out crash report) then the entire pc goes in to restart mode.

Sounds like a problem with HD integrity, maybe try a check-disk on your HD with Repair enabled; it could be a broken Bin on your HD or a broken MFT. A Checkdisk repair does fix that.

Maybe also have your OS do a validity check on all critical files, I have forgotten the MS tool that is available for that. Have to work now, google it ;).

1 Like

thank you, I’ll try all of your suggestions!!!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.