Unable to load game

Hello everyone,

I am unable to load my airport at all. I have tried 3 times, and it always gets stuck on loading the rooms.

My mac will show me the “colour wheel” and tell me that the application is not responding.

Thanks, Ethan

How large is this airport? Really large airports do take several minutes to load, otherwise there might be a loading issue.

My bigger airports take up to 3/5 min to load, but always finish loading eventually.

1 Like

Are you running any mods? If so, try and disable all mods and see if the game will load without mods.

I fighting the same problem, it can take up to 15 minutes to load.

seems it’s struggeling when “loading rooms”… most times it helps to make a single mouseclick, and then wait till “windows-circle” changes back to aceo-mousetip. and then wait till loading is finished… :-S

Should ‘Shorter load time of save files’ be allocated as a feature, or is it stated as a bug/improvement in your Jira list?

It’s not a feature in that sense no, it’s something we’re continuously working on improving. There’s no drastic changes we can make as of now to reduce load time for really large airports, i.e. in one update cut the loading time in half but we do minor improvements each week which eventually may sum up to that compared to previous versions. I’m pretty sure we’ve cut the loading time in half as of now, compared to a really old version of Airport CEO.

Hi Olof,

My airport is medium sized. I heeded your advice and this time, let the game load for just about 10 minutes and when I almost gave up again, the game finally loaded.

I think that the status bar being jammed at “loading rooms” for 5 minutes and my computer telling me that “application not responding” was very misleading and led me to shut down the game repeatedly.

Despite the slow loading, I notice that the game has become much less laggy in the recent updates. Thank you for your continuous effort in making this game even better.

Thanks, Ethan

1 Like

That’s good to hear. We’ve identified an incorrect text setting for the loading bar as “loading rooms” does not only load rooms but also items, Fredrik has done multiple minor improvements to the loading procedure as a result of this discussion (non we’ve measured fully) but this is just another example of how we iterate and slowly improve stuff based on the discussion on this forum! :slight_smile:

Hopefully you’ll at least see some improvement with Alpha 27.5-2.


Can’t load my airport… Updating grid… Stuck there fore about 15 till 20 minutes… Airport was quite big… 35 Stands… And around 4000 People… Please help…

What are your hardware specs?

Windows 10 home
Intel I 5 7300 hq 2.5 GHz
Nvida gtx 1050

There might be a loading issue then, although such large airports do take a lot of time to load given the sheer amount of objects in the world.

If you file a bug report and include the save we will expedite the issue on Monday! :slight_smile:

Is it possible for the game to start pre-caching objects while you boot the menu / enter the load menu / etc… so when you start loading the game, it knows about the object list already?

I’m now having the same issue; it seemed to start after adding a mod. Most of my saves seem to be hung up on the loading businesses page. I don’t know if it is important to note, it never switches over to the gameplay sound effects, like it usually does during the load sequence. Instead, it’s just the load screen’s loop effects minus the music.

Edit: Submitted a bug report, ticket 6340.

This screenshot you posted in the bug report will give you a hint that the mods you are trying to load are corrupt. I would try them one at a time to find out which one doesn’t work and then contact the mod creator. We cannot fix it from our side.

Yeah, I found out which Mod it is, and commented in Steam so the creator knows. Thanks!!

1 Like

Since im not available to create a topic i will just write my bug here.

I cant load my save game, the game just chrashes and closes.
I thought that maybe some objects make the save file to chrash so i tried creating new game, save it without building anything and load it again. That makes it chrash too. Happens in both experimental and stable version of the game.

Not sure if it only happens to me or everybody else…

Did you disable all the mods and switched on the default to see if it will load then?


Have you varfied the integrity of the game files through Steam?