Tutorial step not completing 'Build Service Road...' [Temporary fix available]

The step ‘Build service road and connect from vehicle checkpoint to stands’ remains unfinished for me even though I’ve clearly completed the step.

https://i.imgur.com/xuvdVWN.jpg As you can see in the image there is a vehicle checkpoint in the bottom right corner and yes that is a service road that goes up and connects to the small stands, I have triple checked it and had it rebuilt as well.

As you can see here: https://i.imgur.com/CdqPMA3.jpg The step remains unfinished. My GA planes have no problems refueling. Which tells me this is a bug.

If you look closely here: https://i.imgur.com/desmtl4.jpg you can see that I have actually completed all of the steps in step 5, but because this one step in step 4 isn’t completed I can’t seem to progress.

Can you try restart Steam to see if it updates to the latest version? A hot-fix has deployed shortly after discovering this.

I’m experiencing the same issue. My game appears up-to-date (no steam update after I’ve restarted steam app). I’ve also tried to verify local game cache to force steam to update the game, yet there is no update. I’ve also (after doing the previous two things) tried to go back in game, demolished part of my service route, then rebuilt it (hoping that it’ll proc the game to recognize my already connected route), but there is no change: the game still doesn’t recognize my completed route and doesn’t let me complete the “connect from vehicle check point to stands” part. Please look into it since as long as this tutorial does not complete, new ones won’t start.

As allenxxo posted, after restarting steam and verifying cache I did not download any updates at all.

No, yea apparently the hot-fix did not solve the issue. The problem is that I am now at work and cannot get home and fix it until later today. If it is urgent, there is a temporary workaround which maybe will work:

  1. Go into the GameData.json file in your save file (make a copy just in case).
  2. Find the property “currentSmallAirfieldTutorialIndex”.
  3. Increment this value by 1 (so if it is 1, set it to 2).
  4. This “should” force the tutorial to move to the next step.

Save file location:
On Windows:
Save file: C:\Users\YOUR USER\AppData\Roaming\Apoapsis Studios\Airport CEO\Saves\SAVE FILE NAME

On macOS press Shift + Command + G and input the following to the input box:
Save file: ~/Library/Application Support/unity.Apoapsis Studios.Airport CEO/Saves

1 Like

Thanks for this. It unlocks the regional airport tutorial. Sweet!

I think it partially worked. Now new tutorials are unlocked and the small air field one should be considered completed. However that particular task of “build service road…” is still marked incomplete, which I hope won’t cause any problem later on. For all purposes that I care, it worked. Thanks!

Yes, I know. But at least you should be able to continue with the tutorial.

Some advice I would give on the tutorial Step 4 of the regional airport is ‘waiting for staff to arrive and go to staff room’ seems somewhat annoying. Basically, if you don’t follow the tutorial to a tee and happen to accidentally skip ahead (for example youre a new player), you might end up with security stations manned with security, but you can’t actually progress in the tutorial unless the staff literally enter the staff room. Just a thought.

Either way happy that temp fix worked thanks Fredrik :slight_smile:

Also, I’m not sure if this is a follow on bug but I’ve had literally hundreds of customers in my 3 stores (2 shops 1 food) yet I apparently haven’t fulfilled this step?

This is because a new sales counter was introduced. If it is an old save, it will be set to 0 even if you have had customers before. You will need to get some new customers to complete this step. Remember the tutorial is more designed for airports starting from scratch.

1 Like

That is weird because I’ve just had a lot of people come through and still have not fulfilled this step as you can see here https://i.imgur.com/MtYI7fg.png

Just to clarify the above picture, in each of the 3 stores there are people and they have bought something.

I completely understand where you’re coming from though, the way I’m going about it isn’t exactly the way the tutorial is intended. Although maybe it is a good way to iron out bugs aha.

Yes, it is very good to know what steps is causing problem. We plan to deploy a new fix later today. :slight_smile: