The Ramp Agent Bug

Hi, I’m having a problem and I don’t quite understand why… A person cant find a securty check point yet it is literally right in front of him?

I have this same problem too. I currently can’t find a fix for it.

1 Like

Yeah, weird. Even tried putting a security desk right in front of their noses - still no.

I had a similar issue, but it turned out I had a small strip of non-secure seperating the gate from the secure area with the gates.

My stations are fully staffed and am still having the issue

  • nvm -

the bagage area that was secure, could not be cleaned for some reason.

Right, my bad, but security was working on the upper side of the airport. I’ve activated 1 security point and it seems like the janitors found their way, for some reason the ramp agents can’t.

Edit: Seems like the janitors can’t not as well

Hey peeps,

You are not doing anything wrong. We have possibly detected a bug here that can be solved by saving the world and reloading. Does this work? We will patch it tonight and push an update together with some other fixes.

Write back here if it does not work.

Edit: Changing the name of the topic to better reflect the issue.

Awesome that you guys are fixing this. I’m still asking, is there different logic and- or restrictions to how staff move ? This because Ramp Agents works perfectly fine as long as i have sidewalks and staff corridors all over my airport.

Since ACEO for now is just one floor, this is a pain in the A** to make work, so the fix is anticipated.

Loving the game guys

1 Like

Have you built crosswalks over the roads? That’ll get most people going.

And regarding the walking restrictions, this is the fundamentals:

There are two zone categories, generic zone and specific zone. For the generic zone category there are two types: Open zone, which is the same as no zone at all, and secure zone. For the specific zone category there is currently only one, staff zone but will later be expanded with priority zone (for wealthy passengers). Persons have different permissions that permit them to walk in different zones, these permissions are divided into four categories (but can really be mixed and matched in any way under the hood).

Unrestricted access: Contractors can walk anywhere that is not occupied by a structure or item that is not flat (i.e. road or tarmac). Contractors cannot pass through walls or other buildings, no one can pass through these objects. Contractors are the only ones to walk on grass, everyone else must walk on some kind of structure (sidewalks, terminal foundation).

Global access: Security personnel can walk over open secure zone and open zone borders and do not need to pass any security check-ins or exit.

Staff Access: All employees can enter staff zones and are allowed to walk there, but if you combine a staff zone and a secure zone all employees (except security) will have to pass through a check-in.

Open Access: Passengers have open access only and to pass into secure zones they must pass through security, to leave it they must pass secure exits.

To cross roads, everyone except contractors must pass over a crosswalk.

In different save games I’ve tried reloading and it initially works, but stops after a few minutes. Janitors eventually cross the security point but only clean a couple of tiles and then back to the non secure area and complain about no path. It’s a recurring behaviour.

I’ve had no problems with ramp agents as other people have had, though, I think it’s because they don’t have enough agents to cover the cargo bay and gates at the same time, ando/or no path (crosswalks and sidewalks to the gates).

Exactly this conditions I have in several saves and same issue. The Janitors do clean tiles in secure area, but turn back in unsecure and complain about no path. Few Seconds later they go through security, clean and quick go back in unsecure and complain :wink:
I’ve sent savefile via Bugreport yesterday (

Btw, congrats to this extraordinarily great game!! I’m in various early-access, but Airport CEO is many steps further than other games after early-access release! :heart_eyes:

So sorry, this is not a bug. I didn’t notice before but the secure zones weren’t connected and that seemed to be the problem.

Once I connected the secure zones it worked. It’s just kind of misleading telling that they can’t find the security point yet the problem is that they can’t which secure zone to enter.