Stuck at Loading Screen

Hello, i’ve just purchased the game and now i’m stuck at the loading screen.
I’ve tried several things like disable the Firewall, Update Windows and restarting Windows but nothing helped. Please help me because i just want to play Airport CEO

Can you tell us wich loading screen you are referring to? (The loading screen for the main menu, for starting a new game or loading a saved game?)
Also, could you try posting this under support next time?

I mean the Loading screen when starting a new game.

Try to verify your game, perhaps something is missing. To do so right click on Airport CEO in steam, click properties, and go to “Local Files”, then “Verify Integrity of Game Files”

Done that. It said that notihng was missing.

How long have you waited for the loading screen? What does it say, does it make any progress?

I waited about 10 minutes and all it said was:“preparing buisnesses and mods” and it did no progress either.

I’ve got this problem as well, in my output log, it says “NullReferenceException: Object reference not set to an instance of an object”

I’ve also got many errors on line 294.

Are you playing with any mods? If so try disabling them and then trying to start the airport. Otherwise maybe try again? I think I have had this problem too. If it gets stuck on loading businesses then I just close it and try again. Usually works for me.

No, it is freshly re-installed. I’ve tried running it through the files with administrator as well. Didn’t seem to work.

In that case, it sounds like a technical problem for the devs to check out.

Ah, okay. Do you know where I can find a support email of any sort?

Hopefully one of the devs might stumble upon this post and be able to help out (they’re usually always on and very helpful), otherwise Airport CEO | Connect

1 Like

Send the output_log to if you can’t make an ingame bug report.

1 Like

I have this problem several of time, you can try by clicking on moding menu on first screen and than you will see all mods. Unclick all your mods than click on update arrow on top of screen. After that you can click all mods you need to play again and go back to main menu and continue playing. If you have no mods install click the green arrow (update arrow) anyway. Than back to main screen and continue playing. good luck, its works for me :slight_smile:

Hello all and @Fa397bio, what is the status of this issue? Are you still having the same loading problems or did you manage to get it solved?

Hi, can you please post this log to me in PM? It probably contains the issue with your loading.

I still have that issue

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.