Staff disappearing, workers not available

Hi all,

I entered my save game to find I had no workers (it said -20 available, see image) or staff available. The staff and the entire board had vanished. I re-employed all the staff and everything was fine. I loaded the game once again and had the same issue.

Also, the workers had disappeared. Showing -20 available for call out. I cancelled the contract with the building company, and signed a new one but instead of the advertised 131 being available, only +20 were.

This has only just started to happen. Not sure why. Previous loading of the game had no issues.

Also have various vehicles stuck around the airport. I’ve tried clearing road nodes but that didn’t work.

Thanks.

2 Likes

You definitely need to put that in as a bug report from the main page of airportceo.com.

I had yesterday the same error.
-12 workers and all my employees fired and all contracts rejected.

Did you find a way to fix it?

My airport is huge now, I’d hate to start again.

No not at the moment. I want to play a bit with the save files to correct the workers count. But I think there is a deeper bug on bigger airports and some constellations. Or maybe comes out from using F10 commands.

When I’m back at home on weekend I will try it and also send @Olof and @Fredrik the save files. During the week only able to test on another machine …

I want to bump this thread. I also got this problem today. When i loaded my savegame all my staff was gone and all my contracters. Also at the construction menu it tells me i have -49 contracters available. Please fix this problem. I think this is the third time now i got this issue.

Did you found a way to fix this in the save files? I can’t build anything now because i can’t get any contracters.

Me too now. Bollocks

I have the same problem. Not only staff, but also all my vehicle disappear, and there’s no airplane landing although I have it set it at the Flight Plan

What game version are you on?

My game version is alpha 0.25.2.2. I have tried to recruit new staff and procure new vehicle, save the game, but after I load my saved game, all of the staff & vehicle dissapear again. Please fix it, it’s a really annoying bug, sorry :disappointed_relieved:

Sounds like you actually can reproduce it, which is great. For the save that this occurs can you please .zip all of the save files as well as the log files as instructed via the bug reporting tool (错误 - Apog Labs Jira), but send them in an e-mail to support@airportceo.com?

Ok I have sent my save files & the log files via email. We hope the team can fix it. Thank you.

Send in mine too, Ready11Test, same thing happening.

Perfect, thank you both. Will look at it tomorrow.

1 Like

Issue has been found and fixed! :slight_smile: Will make it with tomorrows next Experimental deployment.

1 Like

This happened tonight to me. I rage quit the game over it. Happy to know there is a fix. Any idea on how long until it makes it into production?

Also, will this fix work on saves where this problem has already occurred or will I need to rehire all my staff back and re add all my vehicles?

It’s already implemented on the experimental branch, it’s a loading issue so loading your save should make staff and vehicles appear. Did you play on the default branch when this occurred?

Yes, I played on the default branch. I loaded my save back and they were still gone. Ended up having to rehire everyone and rebuy the vehicles.

Can you verify that you can, on the experimental branch, load the game without loosing your re-hired staff and re-bought vehicles? Just want to make sure we’re not looking at a different serialization bug.

If you saved the game in a state where no employees and vehicles were present it might have caused the staff and vehicles to no-show.