[Solved] Stuck at loading screen - Mac


have just purchased the game from steam and can’t get past the loading screen. Have tried multiple resolutions, windowed mode etc but keep getting the loading bar flickering on preparing businesses and mods.

Any help greatly appreciated.

Running MacOS Seirra


Hello and welcome to the game and forums. Sorry to hear it’s stuck on the loading screen for you. How long have you left it for?

Hi Rubble thanks for replying,

i’ve just tried again and left a good 10 mins still getting this same screen

I can hear game sound in the background almost instantaneously.


Hmmm, try restarting your Mac (what model do you have?) and if that doesn’t work we can look at seeing if the EXP version will load. In steam right click, properties and select the Beta tab to find it.

Thanks, have already restarted to no avail.

I’m on a macbook pro Late 2015 16gb ram 2.3ghz Intel core i7 NVidia GForce GT 750M along with a crappy intel built in card.

Flipped onto experimental and got the following…

1 Like

When you hold the Alt key down when you start the game do you have an option to select which graphics device is used?

1 Like

It’s there as an option but its greyed out and set to automatic.

Okay, well we can look in the player log to tell then. Will say within the top few lines which device it it using.

1 Like

There’s no folder in my logs named Unity? Should there be?

I’ve tried reinstalling the application again but no progress still.

Yes, I think there should be. Manually make it.

Ok thanks, have done, just loaded up again and no log appeared in the folder, assume it should have done?

It should do yeah, but it might not be made until the game starts. Have you made it where you can start a game?

I can load into the main menus, select my settings and click start game, then just stuck at the loading screen.

I have to then force quit so perhaps that is why i can’t generate a log?

Have you loaded any mods? If so, disable them for now. There’s also an upcoming EXP version too.

No nothing, literally purchased, installed fresh about an hour ago. No mods.

Hmmmm, and suggestions @Fredrik?

EXP has just been updated. Try again.

Gave it another go, same result i’m afraid.

Appreciate you trying to help, hopefully we will get there.

Hmmmm, that’s really strange. Tested here and have no issues at all.

Player log up now