[Solved] Security agents stuck and not claiming jobs (ACEO-28128)


Since a few weeks I am experiencing a major issue with my security agents not claiming available job tasks.

The security agents arrive at the airport, but keep on standing around the bus and metro stations without going to their job sites. I fired and rehired them, but the issue keeps persisting. All officers are assigned to a terminal and there does not seem to be a zoning issue.

Does anyone have experience with this same issue or any advice?

Thanks in advance for your help!


I really need some assistance with this issue. The game is unplayable for a week now. Could someone of the development team please have a look into this issue?


Hello! Please include a few screenshots of your airport’s layout with zones enabled. Do you have any terminals assigned?

1 Like

Hey Olof,

Thank you for your reaction!

Please find underneath the print screens. At the same time I have filed another bug report so that you can access my game (ACEO-28128).

Following you see that the security agents are just standing around the transit structure and are assigned to my only terminal, T1. Note that I closed the airport in order to focus on this issue:

On the next print screen you see the ground floor with escalators leading to the security controls and on the right side the unmanned arrival-passport control:

And the unmanned security control and departure-passport control:

Operations panel which indicates the untaken security jobs:

I hope that this clarifies the situation.

Thanks for your help!

Not related to your issue but I see that there are people stuck in closed in area’s on the ground and first floors.


Yeah, it is related to a bug with pax and staff getting off-set next to elevators, escalators and stairs. It has already been reported.

Hey Olof,

Did you have any chance to look at the issue I am experiencing?


Have you tried upgrading to the most recent experimental version to see if the issue happens there? If not then please try that but remember to back up your save.

1 Like

Yeah, I tried with 35.5.1 and the issue is still the same as on the print screens with the security agents still standing still around the transit structures…

I had similar issues and that was due to assignments to not functional terminals…
How many terminals do you have? Can you please click on the not moving agents and check the assigned terminal?


Thanks for your reply!
My agents were/are assigned to terminal 1, my only terminal. I got it solved by creating a terminal area over my terminal. The agents are fully functional again!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.