[SOLVED] Disappearing Textures

So, I loaded up ACEO this morning, and this is what was waiting for me on the load screen:


I thought this might be limited to the load screen, but then I loaded in my game:

So here are some screenshots of which textures are working, and which are not…

Oh - and all my passengers and staff have disappeared…
So, I would say that this is pretty game-breaking…

It does not fix after reloading the game, the airport, and it is the case on all of my airports…

Try reïnstalling the game.
And do you have all drivers up to date?

Hmm, I would try a reinstall and check for any graphic card drivers. What is your specs?

I’m pretty sure of these:

CPU - AMD 6000 series, Six Core, 3.5GHz
GPU - NVIDIA GTX 750 Ti (2GB video memory)
RAM - 16GB
343GB SSD, of which 178.3GB are free

I do not think anything is wrong with the GPU or system, because I have played a couple of other games since, which have run fine., and have more demanding graphics requirements that ACEO.

I’ll try a reinstall, and see what happens… :slight_smile:

OK, I think 23.1 or .2 solved the problem…
Thanks! :slight_smile:

(@pderuiter or a moderator can close this now since it is solved…)