Self baggage drop off connected but not working [Solved]

Hey y’all, finally back playing this game. Made a switch from my MacBook pro to a pc for work and because of my line of work my new PC is much better.

So all that said started a new airport and noticed my self-checking works but my self-baggage drop-off does not work.

Meaning people are using the drop off baggage but no baggage is actually being dropped off and everything is connected.

Every so often some baggage would be dropped off but not every passenger is actually dropping their bag off.

Any help would be much appreciated. :slight_smile:
Love all the new updates since I last played.

I have submitted a bug report. But not sure if this is an actual bug or user error but as mentioned everything is connected and there’s no messages within the game saying that something’s wrong with my baggage system.

And I know my baggage system is working because if I connect a regular check im desk with baggage check in it works fine.

One thing is sure, you don’t need any tilt trays there (you should only use them when you need splitting into multiple separate belt lines and not joining into a single one).

Last time I looked at them, they were working fine for me, but I had only 8 of drop machines in that terminal.

1 Like

Correct. The tilt trays are the reason why they might not find the way.

1 Like


Draw the Line with the blue dashes first and then add one unit (Or however many you need) to be touching it:

Note: this is a moc terminal, it has no funtction and is built on for the purpost of these screenshots :slightly_smiling_face:


The weird thing is that I had it setup that way at first, but im wondering if there is a limit or something. Still cant seem to get it to work… :confused:

I hadn’t had the tilt trays at first, it was kinda my last resort. Still kinda stumped on why I cant get it to work. I do appreciate the input though! :slight_smile:

Wanted to update, still having the issues! To explain further the first one or two seem to work, but as I expand and add like maybe 5 or 6 thats when issues start popping up. Then currently 8 and passengers are using it but not dropping off bags.

Hope this helps !

Screenshot 2020-09-13 171314|690x466

emmm, I found it too, and just build a medium check-in desk then it solved itself…

Sounds like a bug :wink: @JoshStormPilot @LeoChen (and anyone else who encounters this) could you please both bug report it with the in-game reporter and mention the bug number in this thread as a reference for the devs?

Edit: Has already been addressed and fixed by the devs :heart_eyes_cat::

  • [ACEO-32727 ] - Automated boarding desks do not always correctly open flights for boarding

Think you can try pressing B so that you can view the direction of the belts. Also a good way is to check the entire baggage system to make sure there’s a path. And you can share a screenshot with those belt direction arrows afterward.

What does the flight info say on those non working drops? Mine don’t work and they show no flight scheduled in big screen and list of long gone flights below that.

Hello :slight_smile:

I’ve got the same issue.
Bug report => ACEO-33613

I hope it helps !

Have a good day

Me too - reported as ACEO33646

Yip. Same problem. If I save and reload game they start working again for a while. PAX just stand around and eventually miss their flight. Seems like the automatic boarding desks are the bit that is not working so PAX don’t check in and drop off their bags.

My bad on not posting the bug report number. :slight_smile: (Can’t remember what number I had)
Correct me if I’m wrong, but the fix has yet to be pushed out, correct?

Depends on which branch you are playing, on the experimental branch this has already been pushed out, if you are on the default branch it will go live with the first beta release.

1 Like

@Puma has some insights! :sunglasses: - beta 1 drops on default Wednesday evening so unless you switch over you’ll get the bug fix then!


I was playing on experimental yesterday and it was not fixed. Will I need to start a new airport or should it also correct on an existing Beta save?

Well then I can only recommend a bug report and we’ll look at it!

1 Like

Hi. Did submit one previously but will check again to see if still a problem today.