Running Alpha 26.0

I noticed that I am still running Alpha 26.0 on my Airport CEO, is there any way to force an update on it?


Have you tried switching to normal branch, they back to Exp? 26.2 is the latest I believe?

I believe so. Check change notes post :slight_smile:

Im not sure I understand

Change back to the regular version. That will do a update to the stable version. Then change back into the Experimental brach which should then downloaded the latest version of that branch.

1 Like

Plot twist: he was never on experimental :slight_smile:


HA, :open_mouth::rofl:

Never saw that one coming. So used to most I know on Exp branch.

1 Like

This is a deduction, not a certainty

oh, ok thanks!

1 Like

From Internal to Experimental its the same route… the first time I had no clue what had happened to my game; the internal branch was “closed”, so the game did a rollback and did not auto-update to experimental again.


Oh, really? That’s good to know, strange behavior on the Steam clients part to be honest.

1 Like

it still doesn’t want to update, any ideas @Olof?

Maybe try switing branches while rebooting steam between sessions, see if the game updates itself.

1 Like

Try jasper’s recommendation, otherwise I really have no idea. This is however more of a Steam issue than an ACEO issue, so if it still does not work I’d recommend contacting them to see what’s up.

ok thanks

1 Like

will try, thanks for the advice

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.