Performance issues on experimental branch

I have been using the experimental branch for about 6 months, but it seems 26.6.7 is killing my CPU. It is maxing out the CPU which has never been a problem. If I go to the default branch 26.4.4 I have no problems at all running the game.

I am using an older laptop, but haven’t had a problem until 26.6.6 when I first noticed the issues.

Intel Pentium 2020 2.4GHz, 6GB RAM

Any ideas how I can fix it and get back to the experimental branch?

I’ve had the same sort of problems. I’m on experimental branch using a pretty good computer which is well above the minimum spec. listed on steam. As soon as I create a new game everything lags in spikes, making the game unplayable. I can’t even start building.

i had this simllar spikes - just 1 minute lag spikes - its needs something to look in

Please do bug report. The more bug reports sent in, the more data to analyse to help fix these issues :slight_smile:

1 Like


The latest version is currently Alpha 29.6-8 where we removed the service vehicle camera feature which due to inconsistent texture rendering settings could cause these FPS spikes. Do you still experience these on the newest version @psychomeercat?


Hi Olof,
I tried 29.6.8 on the stable branch and was still having the same problems. Having a look at some other posts, it said a new version was available in the experimental branch (29.6.9). Unfortunately, that doesn’t seem to have done anything for performance.


The problem is most likely due to this issue, which we’re currently looking into:


Hi Olof,
I just tried 29.8-0 on the experimental branch as a fix for ACEO-9134 was released to the experimental branch. The performance is a bit better but still lags a lot making it difficult to play.