Navive DLC purchased on Steam don't show in DLC list [solved]

Hi every one.

Via Steam I bought:

Airport CEO - Vintage
Airport CEO - Beasts of the East
Airport CEO - Helicopters

I’ve had the actual game for several years, but didn’t pick up the DLC until now.

In the Steam Library, it says:

“New DLC for Airport CEO has been added to yout account and will be installed along with the game”.

When I start Airport CEO I can’t see any of the Native DLC in the list that I bought. But the Steam Workshop elements are seen in the overview and work fine in the game.

Why don’t the Native MODS appear in the list and how do I make the Native MODS work in the game itself.

Many thanks in advance for any help.

It seems that you specify quite a few issues related to Steam being weird. Try closing Steam completely and then launching it again (achieved on PC by going to the topbar of Steam > Steam > Exit, and then re open once its closed)

Thanks for your reply Humoresque. I’ve tried that, but it doesn’t change anything.

The DLC aren’t in the Mod section. If steam says they are downloaded, you should have them automatic activated in the game. If you want to deactivate them you have to do that also in steam. Did you start a save or a new game and have you checked if you have things like helipad or the vintage medium stand? Some of this things you might to research first.

Oh! OK. Then it seems to work fine. Didn’t realize helipads etc… had to go through R&D Projects though. Thank you very much for the help Faebue :slight_smile: Prob solved


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.