Mouse Pointer is Off

36 is great so far.

2 Things in 36

  1. The mouse is about 4 squares off. I dont know why but ever since the 36 upgrade it is very hard to select things precisely. I have to be about 2 blocks below or 2 or 3 to one side or another to select something.

  2. It is awfully hard to build int he dark when you dont have lights and all that put up. Is there anyway to switch back to daylight since it was taken out of the F10 menu? Is there a hack for it? Json Mod?


What operating system are you playing on?


The only place I have trouble with the mouse, is the repair button for hangers.

Mac Catalina - always worked before

Fullscreen? Perhaps the same as described here:

My mouse pointer has and is never off. I am playing constrution off and sandbox on.

Is the selection also noticeably off for UI menues? We’ve received one report on this via e-mail but the user was on El Capitan which is not supported.

1 Like

On a recent Alpha 35 save I had selection off vertically downwards by 1 tile, but only for the repaint tool. UI menu was unaffected.

1 Like

So the mouse point being off is only relating to the building grid of the game? Not any UI selection whatsoever? @docnzok is it the same case for you?

1 Like

I’m running the latest version of Catalina and cannot recreate the issue (in build). Mouse pointer seems to be dead on for me interacting with both the UI and the building system.


When painting items it appears to jump too. Usually i find it jumps 1 space to the right after a few items selected

1 Like

I did a test so I have a new MAC XDR monitor that is attached to my 16" Macbook Pro.
When I play the game on the Macbook screen, it is good, but when I move the game up to the big display (where I have always played before) it goes off by 5 squares to the right. So if I am over the zone menu, the terminal menu actually comes up. I tried to take screenshots, but the mouse always disappears (so it would be no help to you) when I do the screenshots. I have no idea how to do a mac full screenshot without the mouse disappearing, I could do a video I guess. But Ill let you guys figure it out first.

That’s the issue I have too - my monitors are rotated portrait, so if it is an issue with display rendering as suggested by @docnzok then my downward shift would correspond to your right shift.

Okay I suck at graphics, so I juts took pictures of my screen - Its really a problem trying to play now. It is the same now on my regular mac screen and the external monitor. Gotta be something cause I never had this issues before
Appreciate any help I can get…

Please report it with the in-game bug reporter and share the bug number in this topic. That counts for all the people who have the same issue, the more bug reports the devs have the better they can try find and fix the bug.

Tested it with a new game (36.3-1) on a 15" MBPro with Mojave and I have no issues with the mouse pointer.

1 Like

I haven’t really seen any immediate reports on this except for this topic and a previous bug report, however that player was playing on an unsupported mac version so it was discarded.

Unfortunately we’re not able to test against the new Apple XDR monitor and have tried to replicate it on a normal average external screen here without ability. Are you saying that you’re having the issue now even without playing on an external monitor @docnzok?

Since the BETA - it has been a little better (closer than the 5 squares off that it was) and on the Macbook pro screen everything is okay now.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.