(MAC) Can't get past loading screen when loading old game

I am trying to load an old saved game on my Mac Air running High Sierra 10.13.6. When I try to load the game, I get through the business loading screen no problem and get stuck on the game loading screen. Ive let it sit for awhile and the progress bar doesn’t move. Then when I right click on the app in the menu bar, it shows that the game is not responding. Anyone have any good suggestions or fixes? Thanks!

1 Like

Have you tried a second time? Somethings when I load an old game first time around it fails to load.


I have. I tried it a few times, shut down Steam and rebooted; tried offline vs online. I had this issue before, but none of my airports were the best; so I was alright with it. I haven’t been able to play for a few months and now that the terminal update got released, I’m really excited to get some better game play. So I really don’t want to loose this file which I’ve already put several hours into.

I also unsubscribed from all my mods; so I am running the game with no mods

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.