Loading new/existing airport freezes at game loading screen

Running alpha 30.1-8 on OS X 10.11.6, El Capitan. I can start the game through Steam just fine, and get to the main menu. Then, when I either start a new airport or try to load an existing airport, I get to the loading screen (see screenshot), which then hangs. Sometimes it just outright freezes; other times, the progress bar keeps flipping back and forth between a couple different items (I believe usually businesses and something else).

I haven’t been able to find any smoking gun log files to diagnose. I’ve tried starting the game on the laptop display and the external display, changing the screen resolutions, as well as starting the game with the external display disconnected.

I mac or windows? And do you have a big mods or a lot of mods?

Did you try a different branch/update?

1 Like

I mac or windows?

From the original post:

OS X 10.11.6, El Capitan.

And do you have a big mods or a lot of mods?

I had one mod installed (real US airlines), but disabled and removed it.

Did you try a different branch/update?

I tried swapping to the experimental branch, but got the same issue.

What is your waiting time?

What are you machine specs please? I’m running a 2013 13MBP with El C.


What do you mean by “waiting time”? As in, how long am I waiting to see if something happens? I think I’ve given it 20 or 30 seconds at least.


2012 15", 2.3 GHz i7, 8GB RAM, NVIDA GeForce GT 650M 1024MB

Yes that’s what Jasper means. It can take a short while to load through that section. I’ve know loads be in two minutes before. But that was on large builds and never on a new game.

Can you have a look here please…

And see if anything looks amiss?

Those spec are also better than my 2010 17" MBP that will run the game as well so suspect something else.

I just let it try loading for 5 minutes (timed), with no success. Here’s the contents of the log file you mentioned; nothing stands out at me, save for maybe the missing scripts:

Initialize engine version: 2018.2.21f1 (a122f5dc316d)
GfxDevice: creating device client; threaded=1
2019-04-07 16:31:14.899 Airport CEO[1525:76981] Color LCD preferred device: NVIDIA GeForce GT 650M (high power)
2019-04-07 16:31:14.899 Airport CEO[1525:76981] Metal devices available: 2
2019-04-07 16:31:14.899 Airport CEO[1525:76981] 0: NVIDIA GeForce GT 650M (high power)
2019-04-07 16:31:14.899 Airport CEO[1525:76981] 1: Intel HD Graphics 4000 (low power)
2019-04-07 16:31:14.900 Airport CEO[1525:76981] Using device NVIDIA GeForce GT 650M (high power)
Initializing Metal device caps: NVIDIA GeForce GT 650M
Begin MonoManager ReloadAssembly
- Completed reload, in  0.191 seconds
UnloadTime: 7.693487 ms
DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
(Filename:  Line: 501)

Setting breakpad minidump AppID = 673610
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198070417317 [API loaded no]
Metal RecreateSurface[0x10f439eb0]: surface size 2880x1800
Setting up 4 worker threads for Enlighten.
  Thread -> id: 700001e64000 -> priority: 1 
  Thread -> id: 700001ee7000 -> priority: 1 
  Thread -> id: 700001f6a000 -> priority: 1 
  Thread -> id: 700001fed000 -> priority: 1 
The referenced script on this Behaviour (Game Object 'APU') is missing!
(Filename:  Line: 1775)

The referenced script on this Behaviour (Game Object 'GPU') is missing!
(Filename:  Line: 1775)

Unloading 6 Unused Serialized files (Serialized files now loaded: 0)
UnloadTime: 18.265788 ms

Unloading 14 unused Assets to reduce memory usage. Loaded Objects now: 69561.
Total: 69.647335 ms (FindLiveObjects: 6.705515 ms CreateObjectMapping: 6.703367 ms MarkObjects: 55.910635 ms  DeleteObjects: 0.324831 ms)

Launched Airport CEO 30.1-8
(Filename: ./Runtime/Export/Debug.bindings.h Line: 43)

What does it say right at the bottom of the file. That’s looking okay for now.

That is the entirety of the file. I had to cmd+Q to exit, which could explain why nothing else is there.

I’m going to suggest you try the EXP version. Right click on AirportCEO and then properties. Beta’s tab and select EXP and see how that goes.

How do I ensure the game runs the experimental branch? I’ve opted into the beta, but the tag at the top of the game screen still says Alpha 30.1-8.

The game is early Alpha so it will say that yes.

But is the experimental branch still 30.1-8, or is it farther along?

It’s further along and has more bug fixes as a rule. But my contain new bugs though. I’ve found it more than stable enough though. I’ve been running EXP mostly since it was made available.

Has default not caught up recently tho so they might be the same alpha number until tomorrow’s round of bug fixes!

My record was 7 min loading :smiley: (was old map size btw).

There was a very recent merger, yes.

1 Like
  1. Can you provide the exact hardware specs of your machine? CPU and GPU info for instance.

  2. Not saying that you have to, but are you able to upgrade that machine to any more recent version of macOS?