List of Aircraft in game

Is there a list of aircraft that exist in game. I thought that I had completed the collector achievement (land all aircraft types), but I haven’t been awarded it. I’m wondering what aircraft I’ve missed (or alternatively it’s not working)

1 Like


Should be it… I pulled it from the game JSON list of aircraft.


Actually there aren’t any A330200s in default airlines’ fleet, so you might need to add some mods


Good point @Alexander


That’ll be the one I’m missing then

I’ve mentioned it many many many months ago, we need an ingame overview of all aircrafts with more information, so that everyone understands what they need for which type.

  • Type and may some typical information from Wikipedia
  • required minimum stand size
  • stair truck yes or no
  • min range / max range (maybe displayed on a map with two circles around your chosen airport location)
  • max passenger capacity
  • max fuel capacity
  • optional: list of default airlines using them
  • anything missing?
  • Catering: yes/no
  • Fuel type: Avgas/JetA1
1 Like

If @Rubble’s list is a complete list. Then there is a problem with the collector achievement. I added a mod to get the A330-200, and made sure to count every aircraft type coming in since adding the mod. Still haven’t got the achievement. Something that the Devs should look into.

I pulled the list from the Game so I think something for @Alexander to look in to then.

I’m going to suggest he will want you to bug report your game.

I will have a look at it! :slight_smile: Worked the last time I checked, but will confirm the status.


We need less black boxes, its not just about planes, your scope is to small.


Found the bug! The SAAB340 was incorrectly added to an internal (achievement related) medium aircraft list and not a small one! Also, there actually was an error in the logics that checks that all aircraft types actually landed. Nice catch! :smiley:


I’ve tried again but still don’t get the achievement. I’ve landed another SAAB340 so unless I have to land every type again, there’s still a problem.

Are you in sandbox-mode or have entered any other “achievement-breaking” commands?

Am not in Sandbox, haven’t touched any debug related stuff.

@Alexander it’s working, I just wasn’t paying attention.


Great to hear! :smiley:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.