Just Purchased, Wont Launch

I purchase the game through steam to play on my iMac and every time I try and start the game, I get an error stating “An error occurred while updating airport ceo (Unknown Error)”. I went through all the steps that steam suggests and nothing worked. Any help?

Model Name: iMac
Model Identifier: iMac15,1
Processor Name: Quad-Core Intel Core i5
Processor Speed: 3.5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB

@Rubble you might wanna check this out.

What happens if ypu launch the game with steam in offline mode? (Not the same as offline status)

No idea at all unfortunately, can’t see your VRAM specs there however but that shouldn’t affect an initial launch. Have never seen this issue before but if you can’t resolve it I would recommend refunding the game.

Welcome to the forums. What OS X version are you running. What happens when you click launch in steam?


Thank you for the suggestion, but that didn’t seem to change anything either.

10.15 Catalina

I purchased the game, downloaded it and tried to start the game. It hasn’t worked ever. Just purchased yesterday.

Hmmm, I’m on Catalina and also an iMac. You have Administrator rights I’m assuming. Have you tried to verify the game files?

I am the only user on this computer and I did go through the validation process, of which it states the game files are good.

What happens if you start the game while holding the option key?

Same thing
“An error occurred while trying to update”.

That sounds more like Steam as I don’t think an update for default branch has been released in a few days. Try reinstalling Steam. How much free space do you have on the drive?

1 Like

About 600gb and I will uninstall and report back.


Yeah, does not sound as if the game is downloaded at all. Can you verify the files (right click the game in Steam)? Can you open up the folder and inspect the local files to make sure they’re there?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.