Game will not load

Hey Y’all,

I have a fairly big problem! The game stopped opening!

See video attached!

Any help would be great!


So here are the solution ideas I got;

  1. If you are using double or more monitors, make sure “Select Monitor” at 0:38 is selected to correct one.
  2. Check your firewall and anti-virus if it blocks AirportCEO.exe to start-up.

If these won’t work can you answer these;

  • What do you see on task manager?
  • Can you start the game on windowed mode with lower resolution?

And to other helpers, I think this screenshot is important;

Thanks for getting back to me!

  1. Yes monitor is set correctly, it doesn’t matter witch I select, either primary or secondary, its the same result.
  2. AV disabled complacently, same result (inc windows defender).

Why do you think that screenshot is important? Just interested :slight_smile:


1 Like

Why do you think that screenshot is important? Just interested

I was wondering you suppose to see that void on AirportCEO tab or not :wink: So maybe other helpers had any idea. Looks like your problem needs our master’s help. @Fredrik @Olof could you take a look at this topic please?

Hi, just wanted to add that I have this same problem, but on my iMac, it has never loaded past that initial settings screen, but on my older MacBook Pro, it works just fine. Both running the same OS and software.

Hmmmm, do you have KEXTs different? Any services different? I’m in a very similar setup but not found any load issues.

Not that I know of, I haven’t changed anything in either computer. The iMac was bought from Apple and then restored from my old computer backup. Everything should be the same unless the old computer had some differences that OS updates didn’t overwrite.

That’s strange. Have you tried booting in to “Safe Mode” then a normal reboot?

Just tried that, no change. The only difference I can think of between the computers is the iMac has a Radeon Pro 555 (2048MB) while the MacBook has Intel Iris (1536MB). Both have similar CPUs and the same amount of RAM, just at different speeds for both.

If you hold the option key down when you start the game do you get a choice of output devices?

This is as far as I can go without the app quitting itself. It’s set to the highest resolution, but I’ve tried lower and windowed.

What’s the spec of the iMac and MBP?

MBP: Retina, 13-inch, Mid-2014 Model
2.8 GHz i5
8 GB 1600 MHz DDR3
Intel Iris 1536 MB

iMac: Retina 4K, 21.5-inch, 2017 Model
3.0 GHz i5
8 GB 2400 MHz DDR4
Radeon Pro 555 2048 MB

Your iMac is a couple of years newer than mine, the MBP is about the same. I have a 2010 17" MBP as well and this all works good. Hmmmmm.

Can you look in your player.log for me please. Located in ~/Logs/Unity/

What does that say?

Why do you have a checkbox for not always starting the configuration while i don’t?

You can toggle it to show at the start in the options?

I never had this option anywhere, not in startup, not ingame.

Not sure, perhaps @jasperwillem could help on this one. I’m not that knowledge about Windows anymore. Given I used to be an admin (and developer) for the OS I understand. I stopped being an admin when Vista was launched and I didn’t move forward with it.

I don’t have a Unity folder in the iMac, only on the MBP

That’s a clue. Reinstall Steam and the game then.