Game no longer launches

Hello. I have been playing Airport CEO for a few years now without issue. I went to launch the game today, after not playing for a few months, and the game doesn’t launch. I get this popup for about a second before it disappears and the game does not launch.
Airport CEO

I have tried removing all my workshop mods, uninstalling and reinstalling, removing the folders located in the AppData folder on my computer, and restarting my computer. Nothing seems to work. I tried to submit this as a bug report, but I get this error.
“(my username) doesn’t have access to Jira on .”

Not sure what to do. I tried searching for this issue on the steam app and here, but haven’t seen anyone post with this issue.

My game is fine… What platform are you on?

Also, welcome to forum! :slight_smile:

Thank you! I am running Windows 10 Pro x64 (Version 21H1), and the game was purchased through Steam. The game worked fine when I last ran it, but that was before 1.0 released.

1 Like

Which branch are you on? (Experimental, Default) Anyone else have this?

So I was digging around in Windows Event Viewer and noticed this Application Error. Still trying to research what this means, but here it is.

Faulting application name: Airport CEO.exe, version: 2019.4.25.41033, time stamp: 0x6079ff2e
Faulting module name: UnityPlayer.dll, version: 2019.4.25.41033, time stamp: 0x607a00a0
Exception code: 0xc000041d
Fault offset: 0x0000000000466d7a
Faulting process id: 0x3580
Faulting application start time: 0x01d7614a764766a1
Faulting application path: D:\Program Files (x86)\Steam\steamapps\common\Airport CEO\Airport CEO.exe
Faulting module path: D:\Program Files (x86)\Steam\steamapps\common\Airport CEO\UnityPlayer.dll
Report Id: 074897e4-9710-4534-b901-06da169d1ef7
Faulting package full name:
Faulting package-relative application ID:

I was on Experimental, but after the error occurred went back to Default; uninstalled, reinstalled, same issue.

I don’t know what to say, as I have no experience with this… I seem to be on about the same setup, but have no issues

Thank you for trying to help.

What are your hardware specs?

Have you tried everything listed here?

Do I understand you right, that the savegame is made by a version before the 1.0 release? All my old saves don’t work with the release version. I thought, that this is the normal case… :thinking:

Hello. I had tried the resolution suggestion listed, but that did not work. Ultimately, I ended up reformatting my computer (I had been meaning to do this for a while), and after reinstalling everything, Airport CEO started to work again. I never did find out what exactly caused the above issue. It seems like it was something going on with Unity Player though.

Hi @Manni, No there was no issue with loading a save game. It was an issue of not being able to launch the game at all. I was just mentioning I had not played the game in a while and it was working pre 1.0 release. I’m really not sure what was causing the problem in the end.

Possible that it’s/was the version of Unity @Olof or are all using 2019.4.25f… as in Zenidars screenshot at the top?
How is the engine acually working in combination with other games? Has every game it’s own version of Unity or do they share the engine?

Airport CEO runs on Unity 2019 LTS (which stands for long term support) where 2019 indicates the major version of the engine (a new one for every year), 4 indicates the quarter year version (a new version for each quarter so 4 is obviously always the latest one if the version is on LTS) and then the last number simply indicates the current release version. 25f is on the default branch and 26f is on the experimental version, the changes between the two are very small as those updates only contain bug fixes. We tend to follow along with the latest LTS release as long as they don’t crash something, which in fact 27f and 28f do. However in this case, there is no reported issue running on either 25f or 26f and the upgrade between the two do not impact any aspect of executing the game.

Since a reformat solved it the issue was most likely tied to the client. Unfortunately we’ll not be able to tell what it was but at least it’s working now and it’s always nice with a fresh PC! :slight_smile:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.