Game crash when launching [solved]

Since yesterday, the game crashes every time on launch (not on loading a save). Tried verifying game files, tried uninstalling/reinstalling, using -force-d3d9 and all the other steps here
The game ran fine yesterday, and nothing has changed since.
Sometimes the game gets far enough that the text on the main menu does the animation, but when I click any button on the menu it crashes. Sometimes it crashes just as the planes are starting to fly across the screen.

PC Specs:
Ryzen 5 1600AF
RTX 2070
32gigs of ram
2.5gigs free on ACEO’s drive.

Log file below:

Mono path[0] = ‘Z:/STEAM ZZZ’S/steamapps/common/Airport CEO/Airport CEO_Data/Managed’
Mono config path = ‘Z:/STEAM ZZZ’S/steamapps/common/Airport CEO/MonoBleedingEdge/etc’
Initialize engine version: 2019.4.26f1 (e0392c6b2363)
[Subsystems] Discovering subsystems at path Z:/STEAM ZZZ’S/steamapps/common/Airport CEO/Airport CEO_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
Version: Direct3D 11.0 [level 11.1]
Renderer: NVIDIA GeForce RTX 2070 (ID=0x1f02)
Vendor:
VRAM: 8031 MB
Driver: 31.0.15.1694
Begin MonoManager ReloadAssembly

  • Completed reload, in 0.222 seconds
    D3D11 device created for Microsoft Media Foundation video decoding.
    Initializing input.
    Input initialized.
    Initialized touch support.
    The referenced script on this Behaviour (Game Object ‘TerminalAudio’) is missing!
    (Filename: Line: 334)

The referenced script on this Behaviour (Game Object ‘TaxiwayClosed’) is missing!
(Filename: Line: 334)

UnloadTime: 1.283200 ms
Instantiating Steam manager…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Instantiating GOG manager…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Signing user in using Galaxy client…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Localization]: Data loaded! Dictionary contains 4336 entries!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

DLC 2027337642 installed False
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

DLC 1587865064 installed False
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Setting up 6 worker threads for Enlighten.
Thread → id: b628 → priority: 1
Thread → id: 7388 → priority: 1
Thread → id: bd4c → priority: 1
Thread → id: 2374 → priority: 1
Thread → id: bd38 → priority: 1
Thread → id: bd00 → priority: 1

1 Like

Ended up being fixed by reinstalling the game for a 4th time. No clue what the issue was but now its working so…

Sounds weird but great you got it working. Maybe it was a bit flip?

Jokes aside, let us know if it starts acting up again! :slight_smile: