Game Crash on Start [solved]

So the game crashes while I try launching it on the newest version of the Steam launcher. I tried it with Tweaks and without, and both times the game crashes on load. The files are all verified too. Any clue why this is happening?

1 Like

Was it working before you used the Tweaks?
If you remove them (including the Framework), a full reinstall of the game is recommend.

How does the crash look like? Is it a box with a plane logo?

1 Like

Do you have any update on this?

I think it has been solved on Discord. But it’s not really clear why it worked now.

1 Like

It seems to have worked, but no clue why it does now but not before even though I didnt change anything.

Make sure that you didn’t have mods overload. I learned that i used my conventional office laptop to play airport ceo with mods. Many more mods that you’ve installed in airport ceo. It would damage the game session

I know about that. It is fixed already

Having the similar problem now. Game just would not launch. I don’t use any mods at all. tried restarting the pc, reinstalling etc and nothing works. any idea?

Hi All, Big fan of CEO and have a great one running at the moment.

Trying to load the game and keep getting suck on this screen. Like program goes unresponsive, curious of any suggestions/workarounds?

I would suggest that both of you either start new threads as they may not be the same issue as OP had here, or contact us directly at and we’ll try to help you there.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.