Crash at load SOLVED

Hello I reinstalled the game the other day. I am playing at the latest stable version. 1.0-33
I also started from scratch so it’s a new save also.

I have no traffic or passengers at my airport yet since I am still building it.
I do have some employees.
But now when I try and load my airport it get stuck at " Loading Agents" and it does not move from there and I’m forced to close the game.

Then start again and try and load it again.
So far it has happened three times in a row.
The forth time it did load.
Is this a bug or what might be causing this?

I thought it might a mod issue, but it still happens even if I have no mods, I do have a few things from the workshop. But that should not cause this.

Uninstall it again. After that, check of following folders are removed as well:

C:\Users\ {username} \AppData\LocalLow\Apoapsis Studios
C:\Users\ {username} \AppData\Roaming\Apoapsis Studios
(save your savegames and native mods in there somewhere else before you delete this folder manually)
If there are also folders called APOG Labs, remove them as well.

Also cleanup the steamapps\common\Airport CEO directory if it still exists.

If you have tools like CCleaner, may perform also a registry cleanup.

Then you should have a cleaned device and you can start to reinstall it.

Will try this and move out my mods folder and save game folder first.
I do not wanna start over again haha :stuck_out_tongue: Thanks for suggestion. Will get back to you. Also I don’t have CC.

Do I have to re-subscribe to the items in the workshop?

Okey, Uninstalled and removed all the files mentioned. Also checked and hade no files left with either of the names. Also deleted the file in Steamapps common.

I will now install the game. Put in my mods, save game, and fix what I had in the Workshop.

Anything else I should do or try?

if it works now. Then not :stuck_out_tongue:
But if it still doesn’t may check all other drivers and updates on your computer. Then it might be not an issue with the game.

Sounds good :slight_smile: Just finished subscribing to workshop items, and will put in the mods and save files now. I do agree, if it still happens it has to do with my computer, (high end tho) or mods and/or workshop.

So update. As I said. I did like (you) @andyc said.
After installing and butting back my save file and mods.
I also updates my graphics drivers.

I have started and loaded in my save many times now. At least 20+ times.
I’ve tried with and without mods and with many and few mods just to see if it makes a difference.

It does still happen that it gets stuck at “Loading Agents”
Before it was 8/10 times. Now it’s like 4/10. So considerably better.
But it still happens.

If you have any suggestions on what I can try and check let me know.
I have no idea if it’s game related or not. This is the only game that behaves this way for me.

I did get the question if I have enough VRAM, and I do. More than enough.

How large is the save you’re trying to load?

I would say pretty big. I have finished all building and so on. If I check my folder it says 75MB.
But I also wanna point out that this accrued in the earlier stages in my build, probably before it was 75MB, And today it’s been working fine. No problems. But not yesterday. That is also a bit interesting.

At 75 MB you’ll most likely have, regardless of the power of the device, some waiting time before the game fully loads. At really large saves Windows can in certain instances think that the application is not responding which is not the case as it is simply very busy recreating all of those objects. If that window appears again claiming that the application is not responding I advise you to click “wait for the program to repond” and give it time to complete the loading. That’s also why it appears to only work “sometimes”, as the loading speed of the save can vary depending on what other applications your device is busy with (this can also include background tasks and not necessarily other active applications).

Yeah I understand that :slight_smile: I will try and be more patient when loading if it takes time :wink: I usually do give it a few mins if it gets stuck.
But I should have to wait for 10 mins? Sometimes I just waited it out too see if waiting is helping haha.

Yes, it is very possible that it could take more than 10 minutes. An airport that contains at least 75 MB of data is considered extremely large as it probably contains well above tens of thousands of separate objects (including agents, vehicles, walls, furniture, floors and so forth). In reality this is way more than what we’d really like to support but on the other hand we don’t want to limit players either with too many hard set limits, this is why a game like Airport CEO is so difficult to work with - it expands from a small grass field into a large international hub but must do so on a wide array of different devices spanning really old MacBooks to beasts like your machine. Of course, the entire serialization system in ACEO is just like the rest of the application built on architectural principles that we would not utilize today and so loading in a potential future ACEO 2 would be a lot faster - however overhauling this part of the application would mean overhauling the entire game’s architecture which is not something you do for a released product.

1 Like

Oh okey :smiley: Cool explanation. And thankyou <3 :smiley: Then let’s put this as solved :slight_smile:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.