Corrupted save


I wanted to play some more Airport CEO today, but when I tried to start the game it said “install game” in Steam first of all. I’ve had a look in my steam folder/appdata to see all data was still there, so I clicked install and it verified my game files. I started the game, clicked continue airport only for the game to continue my previous saved game instead of the last one I was playing.

When I click load game I can see my last save game all the way at the bottom, yet I get an error when loading: Warning, an issue was detected during the loading process of this airport. Please file a bug report using the in-game bug reporting tool. Pressing OK will open the tool immediately.

Here’s a wetransfer link containing both the corrupted save folder, the ACEO_issue_log and the last 5 persistent logs. The 02:54 save is from when I stopped playing the last time the save worked properly. The 3 after that are from trying to start it. I’ve also tried overwriting some of the save files with other files and see if that worked, but it didn’t.

I really hope there’s a way you can rescue my airport!

My mate has had a look and identified GameData and PersonData to be corrupted. Overwriting these with the data from an older version of the save means I can at least load the save and with some minor rollbacks and inconveniences. I still have no clue why this happened but I’m happy I don’t have to start over.

If anyone ever has to replace these files, make sure to close and reopen your security points and baggage bays. Also any added runways need to be reopened.

This issue almost always happens when the disk is about to get maxed out, do you have a lot of disk space available?

I’ve got plenty I think, at least 50GB on both disks. I’ve got a 256GB SSD and 1TB HDD, savefiles are on SSD and game is on HDD.

Do you remember if there were any exceptions or irregularities invoked as you saved the game? Has it happened before?

Thanks for having a look Olof!

Saving and quitting the game went as normal and I’ve never had corrupted savefiles before. In hindsight I remember my laptop not going into sleep mode as normal straight after the game, the screen went black already but the keyboard was still lit for a minute before I used the power button to switch off the pc.

I’m using Steam cloudsave so I’m guessing there’s a chance that this may have impacted it? I can imagine the uploading to the server not being finished properly and then the game downloading these corrupted files the day after. This still doesn’t explain entirely what I mentioned in the first post though: Steam showed the game as not installed so I had to click the Install button which then seemed to verify my game files.

I see, thank you, we’ll keep a look out. Unfortunately since the data is lost on those documents there’s nothing we can do, but at least it can be saved by the steps as described above.

‘Autosave’ is a big help for me…


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.