Catering not working [solved]

Hello everyone,

I was wondering if someone else is also experiencing issues with the catering feature.

Visually everything looks fine:

  • truck loads meals in the depot
  • drives to the plane
  • unloads them

But then on the plane view, catering remains “Catering in progress” with 0/XXX all the time. This leads to planes running into delays and not departing.

Anyone else has this issue?

Hi and welcome.

I just did a test and in my case it gets green.
are all catering trucks busy or are some still available?

1 Like

yeah there are more available but the truck went to the plane and unloaded meals at the plane but they were not counted in the screen and so, the plane keeps delaying the departure

Can you upload your savegame to Steam and put a link here? Then I can take a look. Might be easier than guessing.

The Steam upload Icon is in the main menu → load airport

1 Like


Thanks for the help

1 Like

Are you sure this is the affected savegame? It looks different to your screenshot above and catering service works well.

1 Like

It happens to me in every game, no matter which one I try. Own built ones, other savegames, always happens for me.

Truck before unloading at the plan:

Plane before loading meals from truck:

Truck after unloading at plane:

Plane after loading meals:

Here you can see, “Catering in progress” although the truck already unloaded and drove away again

Strange. Even with those one passenger flights it worked for me. :confused:

Do you notice a bad fps? When yes, what are your hardware specs?
And do you play on version 1.0-30? Can you try to switch to Experimental?

You can change in the Steam Library:
image image

1 Like

Just found it.

My passenger ratio was set to 0% :slight_smile: That’s why I also inly has 1 Pax all the time. now it also loads catering :slight_smile:

Rookie on the game :slight_smile:


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.