Bug? Baggage do not show on coveyor belts


I would like to know if this is a bug or not… Because when I check my conveyer belts it seems there’s no baggage to be found and it will only show a green circle when I follow a luggage…

Here’s some of the pictures

Thanks in advance! :airplane:

2nd Pic

Can you see them when you zoom in? Also which settings (resolution, monitor, quality) did you choose when you start up the game?

Even though I zoom in very closs… Here’s my setting 1280x720, Fast


Can you try a setting other than “Fast” and see what happens?

I have tried good and still no baggages seen on the conveyer belts

Does this issue happen on the experimental branch?

What do you mean by Experimental Branch? Is it about using beta? If yes I’m not using the beta version

There’s been an update to the game today, does it still happen? If so, what are your hardware specs?

Yes I have updated the Game still no baggage showing then after opening the saved airport there is a flickering of lights…

Here’s the video… Airport CEO Flickering - YouTube

What are your hardware specs?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.