Airport CEO Alpha 24.2 released

Hello! The holidays are over and we’ve tried to be a little less productive during the vacation week but… it’s difficult to stay AFK. So, 24.2 is now being released and contains little new except for some minor null reference exception handling and a responsive UI! No more forcing to 16:9 but all resolutions should be supported (21:9 does have a slight bug right now which causes some panels to not be fully visible).

We’re rolling this out now so that you who has an aspect ratio different than 16:9 can test how the UI adapts to your screen and, if it breaks something completely, roll back to the default branch and enjoy that sweet, sweet forced 16:9 (lol).

We’re happy to see any bug reports relating to this be accompanied by screenshots so that we can understand the issue and solve it. This is just the first part in the UI overhaul and we’re currently looking at a complete overhaul of the management panel and its aesthetics.

Change logs below:

    Release notes - Airport CEO - Version Alpha 24.2


  • [ACEO-3020] - Implement responsive UI (Main menu)
  • [ACEO-3024] - Implement responsive UI (In-game panels)


  • [ACEO-3066] - Multiple minor null reference issues

The Main Menu seems to be a lot slower now (in terms of FPS) from before this update.

Well, literally nothing has changed in the code base (except for a few null ref checks) so that’s most likely just coincidental.

Alright, its probably me then.

1 Like

We’re working on that memory leak issue as of now! :slight_smile:


No fuel refill again in 24.2
No fuel arrive to base.
Save in ACEO-3073

I have to say, the 1920 by 1080 is a bit of an improvement! :grinning:


Even with upgrading, when the airport terminal is full of Passenger it slows down and there is a dramatic fall from FPS.

This is still being worked on, this update was only small UI adjustments to accommodate for other aspect ratios. Performance and the suspected memory leak will be looked at in January.

@Fredrik + @Olof I have not been able to play ACEO the past few weeks due to a bug that keeps me on a loading screen whenever I try to load or create a airport. I sent a bug report, but was wondering when this would be fixed, because right now I can’t play the game at all.

A really, really small thing I’ve noticed. Hardly significant in the grand scheme of things really but I thought you may like to know.

A white bar has appeared on the left-hand side of the menu screen:

Do you remember what bug number you got?

What aspect ratio is this?

It is 1920 x 1080 - so therefore 16:9

I didn’t really get one, it just sits on the loading screen…
But is there someplace to check for one?

Hmm, strange, just tried it on my machine and I can’t get the same results. Does this occur every time you launch the game? Are you running you latest graphics cards drivers?

You got one when you submitted the bug but I understand that you wouldn’t save it, just PM me your e-mail and I can look it up. If you’re unable to play the game then it’s indeed a serious bug which we’ve not marked as “Critical” for some reason, probably misread the bug report.

Also, we updated this to Alpha 24.2-1 today for a fix for 21:9 aspect ratios. Got stuck in travel so couldn’t provide a change log until now, sorry for this! Here it is anyway:

    Release notes - Airport CEO - Version Alpha 24.2-1


  • [ACEO-3072] - Some panels not visisble in 21:9 screen aspects

To be honest Olof, I’ve only run it once, but I’ll have another few goes tomorrow and see what happens. As far as I know the drivers are all current (It’s a Mac, if that makes any difference to you)

1 Like

21:9 (3440x1440)

Game map seems fine, but most menu options are cut off. Initial game menu trails off the sides of screen, setting menu has no option to exit game as its missing, probably off the side of screen.

Hmm, can you include a few screens? Either here or via a bug report.

We do not yet have a 21:9 display to test builds with so we’re currently limited to editor testing. Getting a new screen tomorrow so that we can run build tests as of next week.

Further to my original posting, I’ve tried a couple more times now and each time I still get the white bar on the side of the menu. The clouds and planes go over the top of it. It’s not a serious bug as everything works as well as it did before this appeared.

The game proper is not affected.

Same for me.