Adding 7th Medium Stand Causes CTD

Hey All…

Joined the forum after experiencing the same problem in now 3 different saved games…

I grow my airport and as soon as I add my 7th Medium stand, upon loading the saved game the next time playing, it fails to load and crashes to desktop (during the loading structures screen)

Tried both the experimental and stable game. Disabled all mods. reinstalled etc. Same result.

Using gaming laptop, GTX graphics card etc

Any ideas? Thanks in advance. Love the game

(Love it more if I could grow")

Hello, welcome to the forum.

It is really odd issue as game crashes after placing 7th stand. Here are couple of suggestions:

  • Start the game on lower graphic settings and in different resolution. You can also try fullscreen or not
  • Download a save game from Steam Workshop and test if same thing happens
  • Wait a couple of minutes on loading screen. Gaming laptops may have powerful GPU but AirportCEO is related mostly with RAM and CPU.

Tried multiple resolutions…still not able to load saved game files and crashes to desktop.

Loaded a steam workshop item with more than 7 medium stands…worked fine.

Something corrupt in my save file?

Hi and welcome!

Sounds like a weird glitch, which version are you on? Both for the stable and experimental version?
What system do you use, PC or MAC? If you can share some system details that could also help to try and find an issue.
Did you also try to built an extra stand on the Steam workshop item and S&R the game?
Do you have some daylight overview screenshots of your airport, maybe we can spot something.

You can always report it via the in-game bug report system (press escape and then the top level menu), that way the developers will get your save game as well, please describe in detail the steps you take to get the issue. Also an option to upload your airport to the Steam workshop so we can have a look at it.

1 Like

What’s the longest time you’ve let the game load before shutting it down? Note that if windows sais the game is not responding, it could very well still be running but just be too bussy to tell windows….

It doesnt load…it crashes to desktop as the yellow progress bar begins moving…

EDIT: It crashes to desktop whilst “Loading structures”

Asus Gaming Laptop
Intel Core i7-7700HQ CPU @ 2.8GHZ, 8GB RAM, 64bit, GeForce GTX 1060 graphics…

Game version Alpha 30.1.9

I will try to build more on the steam workshop game and see what happens…will advise.

Unable to get screen shots now as airport fails to load. Likewise I wont be able to report bug in game due to this neither.

1 Like

I also get this whilst it crashes to desktop…

This is indeed a strange issue. So just so that I understand, is it this specific airport’s seventh stand that causes the crash or is it any airport you build that has seven or more stands on it?

Any airport…and I’ve tried building 3 of them so far

The CTD begins once I’ve built my 7th medium stand…

Can you upload your save game to an external file site and give its link in here? I am personally interesting to take a look at your save game :wink:

Yes I can…but may need some guide in how to do so…

Best site to use…?

You can find your save game on
C:\Users\[Your Username]\AppData\Roaming\Apoapsis Studios\Airport CEO\Saves

Zip it and upload it to any file share website and then share its download link in here.

Or you can come to AirportCEO Official Discord channel and send it to me via personal message:

OK thanks…will try to get it over some time today

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.