Unable to build baggage belts

Seeing a strange issue today in a career game I have been playing for awhile, Beta 2.2-3 version. I have one terminal completed that services only small aircraft, with a full baggage system.

I am nearing completion of building my 2nd terminal that will service medium aircraft, and, I’ve run into a portion of the map where I am not able to build baggage belts. If you look at the screenshot below, even though the belts haven’t been “built” by the contractors, you can see 2 issues that I have run into:

  1. I am using high speed belts. I am trying to connect my baggage line that comes from the check-in desks and goes to the baggage bay. In the screenshot, you can see it is completed and goes to the UP baggage escalator. But, if you notice, the last 9 blocks are normal belts, not the high speed belts. No matter what I tried, the high speed belts would not build in the same spot. It was not a lack of money issue. Whenever I clicked and dragged several high speed belts to build, the belts would just disappear. There was no error message whatsoever. It was like I never tried to build anything. Even if I tried to only build one block of belts at a time, as soon as I click the spot to build, the belt never shows up and the cursor goes back to looking like I have no item selected to build. Through playing around and trying a few things

  2. On the beltline coming from the baggage bay to the baggage claim area, I am having the same issue. I tried the normal belt instead of high speed belt trick, but it does not work. I also retook the screenshot and changed it from the original one that I had in this post. Look at the cursor when I am trying to place the high-speed belt…it says aircraft stands??? Now, where I am trying to complete the beltline, there are aircraft stands above. But, even when I move the cursor inside the foundation, as shown in the screenshot, it still says aircraft stands.

Anyone seen anything like this before? I have also tried using the bulldozer in that area to see if there was some weird artifact object, but that did not help.

And…as soon as I post about it, it went away. I had saved and reloaded, moved onto different areas, did other things, and nothing was working. Literally was dealing with the issue for over 30 minutes before I finally posted it here.

Now, it works properly again.

Hmm, sounds very strange. Is it happening on beta 3 as well or you have yet to try that version? There’s been so many changes to the build system between beta 2 and beta 3 that we’d rather verify this bug on beta 3 than looking at it on beta 2.

How do I load Beta 3? I have never loaded the experimental branch builds, but for as much as I am playing right now I would be more than willing to do so.

In your Steam library, right click on Airport CEO and click on “Properties”
Click on the “BETA”’ tab
Change the drop down to “experimental”


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.