[Solved] Game freezing every 5-10 minutes HELP!

Hi, after recently installing a new update on the game it has been freezing almost constantly about every 10 minutes… I literally cannot play at all and if I do, I lose my progress. Please, please help me! I really want to play it again. My airport isn’t massive and there is no common reason for it freezing and closing. My computer is a windows 64-bit, Intel i5-7200u and it has 8GB of RAM. Help me please. My computer :grinning::pray:

1 Like

Make sure to file a bug report. Other than that, what can you tell us about the airport? (for example how many pax, how biug you’ve build, etc)

Could it be the autosave? I’m not sure if it can crash your game but it does freeze the game for a split second.

Sure! I can send some screenshots of it. Also how do I file a bug report?

I mean it isn’t massive but I am past the tutorial now.

I don’t have auto save turned on right now so it must be something else. Thanks for the suggestion though :+1:

If you press ESC the menu will open and on the top of the menu you will see a bug report option. You PCs specs and game status will be automatically recorded and sent off, along with a short summary of your issue.

Ok cool!

Please get back here when you have a bug report number for us! :slight_smile:


There may be a few on the system because I didn’t get the code for one of them as I didn’t see your message, but the one I have now is: ACEO-18424. Thanks so much for getting back so quickly :slightly_smiling_face:

Bugreport numbers can be found in the output_log. Keep in mind this file is rewritten every time you start the game so you’ll only find those for the last session. Anyway i’m sure olof will find them all.

Ok thank you, I hope it gets fixed soon so I can play properly again :pray:

You seem to be on the default version of the game, is this correct?

I would suggest that you start by upgrading to experimental and see if you have the same issues.

1 Like

Yes that is true, I’ll try it with experimental and get back to you to see if it makes it any better.
Thanks for the advice :slightly_smiling_face:

1 Like

Fixed now, thank you :smiley:


Cool, let’s see if it lasts and enjoy the new features! :slight_smile:

1 Like