Map Loading Stuck on 'Updating Grid'


I’ve been playing the game for quite a while now. I recently finished construction on a map based on the Calgary International Airport in Calgary, Canada. After moving my desktop elsewhere, I have not been able to successfully launch the map. Whenever the game loads, it will always pause on the ‘Updating Grid’ portion of loading ( Screenshot ). As a test, I left the game running for a weekend where I was out to see if it would load. After almost 48 hours, it was still on the same screen.

I am currently using 7 mods from the Steam Workshop ( Screenshot ). Default contracts are still enabled. I am running on the latest build, however this has been occurring for the last couple of weeks, and Steam has updated the game, so I don’t believe this is a contributing factor. I have tried both the standard and experimental build, and also un-installing and re-installing the game.

The game was loading before I moved my desktop to a new location, so this may be hardware based, however, I restarted and updated Windows and the results still have not changed.

Any ideas?

Seems like you find that one rare thing that can happen with games loading :wink:

Package a copy of your game from the save-game folder, with i.e. WinZip, then email it to”. If there are separate logs with errors in the game folders, attach these logs too.

Put a link to this topic in the email.

1 Like

What happens if you load the game vanilla, i.e. remove those mods?


Sceptical because it worked just fine with them but let’s give it a shot

no change, only new thing is I can hear in game rain sounds

I’d recommend disabling all mods, completely uninstalling the game and purging all files related to the game (via %AppData% which you can search for to find the Apoapsis Studios and Airport CEO folders). There was someone else on the forum previously who had a similar issue and that solved it for them.


Will this keep my save? It wouldn’t be a huge loss to lose it but it would be nice to keep it, if not, no issue

You can move out the save from the saves folder, temporarily to some other folder and then move it back in when the game is reinstalled! :slight_smile:


That makes sense I guess, thanks

1 Like

Ok, so I’m not exactly the brightest, how do you access the saves
via the steam files? (screenshot)

I think savefiles are in ~%User~%Appdata~Roaming~Aposis Studios~AirportCEO~Saves

1 Like

my savepath for the game is Program Files (x86) / Steam / steamapps / common / Airport CEO and then the options after that are what was on the, and none of those are / Saves

savegames are not in the installer folder, they are in the userfolder.

1 Like

I apologise for my major lack of windows knowledge but where is that?

on your system drive (mostly C:), then ~users~%User~%Appdata~Roaming~Aposis Studios~AirportCEO~Saves

1 Like

Copy Paste this and you should be find them :slight_smile:

%appdata%\Roaming\Apoapsis Studios\Airport CEO


Copy it into WIn-R menu.

1 Like

windows is unable to find either of those paths in both the run menu and file explorer
It might be worthwhile to bring up that I’m running windows on a partitioned hard drive from on an iMac and for some reason that’s led to file troubles in places

What if you run a global search on “gamedata.json”.

Do you find anything then?


‘No items match your search.’