BAE 146 fuel type incorrect?

Freaked me out for a bit! None of my Jet-A fuel trucks wanted to go near this aircraft. So it just sat there waiting for fuel service and screwing up my schedule and I had absolutely no idea what was happening so I was dismissing every BAE146 that landed, which the airlines were none too thrilled about. Didn’t even think about fuel type - commercial medium, so Jet-A right? Wrong.

By pure luck one of my 100LL trucks strolled by and serviced it. So that was that.

So I dunno if I’m just late to the party and everyone already knows this or if I need some kind of update (running through Steam) or if it’s a legit thing that actually needs fixed.

At any rate, the BAE146 definitely does NOT run on 100LL.

Just wanted to share! Thanks!

btw - in-game bug reporting was throwing 413 zip file payload too large error at me tonite - that’s why I’m posting here. Maybe airport is too large at this point or whatever, I dunno…

What version of ACEO are you playing?

All the fuelling I have seen for BAe-146 aircraft on my airports have been by Jet-A1 tankers.

I haven’t seen an AvGas tanker go anywhere near my medium stand areas.

1 Like

This bug was present in an older version of the game and has since been fixed so I recommend that OP updates their game to the latest version.


Game screen sez 1.0-36

… latest patch?

Version pic (can only attach 1 pic to replies, sorry…)

Actually, a while ago, I had a “wrong bug”, with some medium planes sitting forever. I simply assumed - evidently wrongly - that all medium planes would use Jet A1 fuel.

I added a 100LL fuel and some trucks, and… problem solved. Sorry, at the time, I did not note which airplanes’ models were sitting.

Thanks Alain, yeah… the BAE is the only one this happened with for me. If I’m running the latest build tho this is strange bc as Olof said above it is supposed to be corrected.

I’m pretty sure I had this same error recently. I’ll see if I can replicate it. I also noticed a job waiting in my GA terminal for jet A1 but didn’t have time to investigate. I’ll try to track down both on the weekend.

look at what I caught:

I had the same problem today. None of my BAE146s would refuel because all the AVGas trucks were assigned to the terminal with small planes or GA only, After I added 2 AVGas trucks to my medium plane terminal, the BAE146s refueled.

If you have a current case, send a bug report and post the number here. :slight_smile:

Mercury-45939 is a Jet-A1 fuel truck filling up a GA flight.
Mercury-45940 is an AvGas fuel truck filling up a medium commercial flight (BAE146 plane).

I am running 1.0-36

But you are sure you haven’t activated the realistic fuel mode in your gameplay settings? If it’s activated then certain GA planes use Jet-A1.

I would also like to know the setting of that toggle… :thinking:

Edit: Seems to be set to “false”. Calling @Fredrik

Have you tried fully reinstalling the game?

We’ll make an update to the experimental branch soon, hopefully that will set an end to this problem.


I don’t recall ever seeing that toggle. I’ll have to check in a day or two.

Use realistic fuel types for general aviation is switched off.
No, I haven’t tried reinstalling (yet). This by itself is such a minor bug that I’m not concerned. My vehicles turning invisible was a much bigger issue. If that happens again I’ll reinstall for sure.